Bug 494644 - Request: better mouse button emulation: mouseemu
Request: better mouse button emulation: mouseemu
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
http://www.biophys.uni-duesseldorf.de...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-07 13:23 EDT by Jeremy Huddleston
Modified: 2009-04-22 04:58 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-22 04:58:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Huddleston 2009-04-07 13:23:03 EDT
Description of problem:

Using a 1-button mouse with linux is a pita.  The mac_hid.mouse_button_emulation fails because it sends the original key press in addition to the emulated button... plus it doesn't support things like control-click for right click.

Other distros (gentoo, ubuntu, debian, mandriva, suse) use mouseemu for this support, but I can't seem to find it for Fedora.

The latest sources can be found here as they've been taken over by a new bugfix maintaier with many patches from debian integrated:
http://www.biophys.uni-duesseldorf.de/~schmitz/mouseemu/

Debian: http://packages.debian.org/unstable/utils/mouseemu
Ubuntu: http://packages.ubuntu.com/source/hardy/mouseemu
SuSE: http://www.novell.com/products/linuxpackages/server10/sp1/ppc/mouseemu.html

It looks like hal might need some patching or settings updated to support this because when I run mouseemu after compiling it myself, the laptop keyboard stops responding (make sure you have a usb keyboard handy to plug in and get control back).
Comment 1 Harald Hoyer 2009-04-07 14:08:20 EDT
why is this a udev bug?
Comment 2 Jeremy Huddleston 2009-04-07 18:10:12 EDT
My brain crossed wires somewhere... I meant hal
Comment 3 Richard Hughes 2009-04-08 04:41:30 EDT
Can you explain why this is a hal bug? Thanks.
Comment 4 Jeremy Huddleston 2009-04-08 04:58:19 EDT
richard, see the last paragraph of the original description:

"It looks like hal might need some patching or settings updated to support this because when I run mouseemu after compiling it myself, the laptop keyboard stops responding (make sure you have a usb keyboard handy to plug in and get control back)."
Comment 5 Richard Hughes 2009-04-08 06:51:28 EDT
(In reply to comment #4)
> might need some patching or settings updated to support this

Such as...

Richard.
Comment 6 Jeremy Huddleston 2009-04-22 03:45:02 EDT
Quoting from the original description:

It looks like hal might need some patching or settings updated to support this because when I run mouseemu after compiling it myself, the laptop keyboard
stops responding (make sure you have a usb keyboard handy to plug in and get control back).

Try it for yourself, but keep a keyboard handy to plug in.
Comment 7 Richard Hughes 2009-04-22 04:58:46 EDT
I'm sorry, but you need to be a load more specific than "patching or settings updated" after you've compiled something outside of fedora that then makes HAL break. 

If I said to you that I had compiled a program from source, and now the power button has stopped working, you would tell me to fix my broken program.

This isn't a Fedora specific bug, and so please can you either email the mouseemu mailing list, the hal mailing list, or open a bug on freedesktop.org. Thanks.

Note You need to log in before you can comment on or make changes to this bug.