Bug 494673 - migrating back the system to the original org from the second org results in traceback..
migrating back the system to the original org from the second org results in ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Other (Show other bugs)
530
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Brad Buckingham
Preethi Thomas
:
Depends On:
Blocks: 456998
  Show dependency treegraph
 
Reported: 2009-04-07 14:23 EDT by Preethi Thomas
Modified: 2009-09-10 15:48 EDT (History)
4 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 15:48:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
additional tracebacks from clicking on broken migrated profile (30.03 KB, text/plain)
2009-04-14 09:31 EDT, wes hayutin
no flags Details

  None (edit)
Description Preethi Thomas 2009-04-07 14:23:32 EDT
Description of problem:
migrating back the system to the original org from the second org results in traceback..

Version-Release number of selected component (if applicable):

Satellite-5.3.0-RHEL5-re20090401.1-i386-embedded-oracle.iso

How reproducible:


Steps to Reproduce:

1. create 2 orgs org1 & org2 with trust.
2. register a system to org1.
3. login to org1
4. give the system management  entitlement
5. from the command line of the satellite server migrate the system to org2
6. migrate-system-profile --username=USERNAME --password=PASSWORD --systemId=SYSTEMID  --to-org-id=org2
7. login to org2
8. give the migrated system from step 6 management entitlement.
9. migrate the system back to the org1
10.migrate-system-profile --username=USERNAME --password=PASSWORD --systemId=SYSTEMID  --to-org-id=org1


  
Actual results:
Error: redstone.xmlrpc.XmlRpcFault: unhandled internal exception: ORA-00001: unique constraint (RHNSAT.RHN_CONFCHAN_OID_LABEL_TYPE_UQ) violated
ORA-06512: at "RHNSAT.RHN_CONFIG", line 180
ORA-06512: at line 1

login to org1 and click on the system profile and notice the ISE


Expected results:

successfully able to migrate back the already migrates system 



Additional info:

traceback on the ISE.

The following exception occurred while executing this request:
GET /rhn/systems/details/Overview.do

Date:4/7/09 2:13:26 PM EDT
Headers:
  host: rlx-0-10.rhndev.redhat.com
  user-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.2) Gecko/2008091816 Red Hat/3.0.2-3.el5 Firefox/3.0.2
  accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
  accept-language: en-us,ar;q=0.8,ja;q=0.5,ml;q=0.3
  accept-encoding: gzip,deflate
  accept-charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
  Keep-Alive: 300
  connection: keep-alive
  referer: https://rlx-0-10.rhndev.redhat.com/rhn/systems/Overview.do
  cookie: JSESSIONID=E104DA30367FBF4BB4A769AC95BFE531; rh_omni_tc=70160000000H4AjAAK; s_vi=[CS]v1|499AD56A000016E6-A3A095600005320[CE]; pxt-session-cookie=95xaa434ea92509ad1f380f47c2c3feef02

Request:
Local Name = rlx-0-10.rhndev.redhat.com
Server Name = rlx-0-10.rhndev.redhat.com
Requested Session Id came from Cookie
Requested Session Valid = true
Session = org.apache.catalina.session.StandardSessionFacade@7c9c7c9c[session=StandardSession[E104DA30367FBF4BB4A769AC95BFE531]]
Protocol = https
Request Locale = en_US
Request Character Encoding = UTF-8
Attribute Names = rhnActiveLang, javax.servlet.jsp.jstl.fmt.timeZone.request, javax.servlet.request.key_size, __sitemesh__filterapplied, javax.servlet.request.ssl_session, javax.servlet.request.cipher_suite, org.apache.struts.action.MESSAGE, session, org.apache.struts.action.mapping.instance, requestedUri, org.apache.struts.action.MODULE,


User Information:
User pt-org1 (id 2, org_id 2)

Exception:
javax.servlet.ServletException
        at org.apache.struts.action.RequestProcessor.processException(RequestProcessor.java:535)
        at org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:433)
        at org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:237)
        at com.redhat.rhn.frontend.struts.RhnRequestProcessor.process(RhnRequestProcessor.java:82)
        at org.apache.struts.action.ActionServlet.process(ActionServlet.java:1196)
        at org.apache.struts.action.ActionServlet.doGet(ActionServlet.java:414)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:690)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:269)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
        at com.redhat.rhn.frontend.servlets.AuthFilter.doFilter(AuthFilter.java:73)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
        at com.opensymphony.module.sitemesh.filter.PageFilter.parsePage(PageFilter.java:142)
        at com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(PageFilter.java:58)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
        at com.redhat.rhn.frontend.servlets.LocalizedEnvironmentFilter.doFilter(LocalizedEnvironmentFilter.java:67)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
        at com.redhat.rhn.frontend.servlets.EnvironmentFilter.doFilter(EnvironmentFilter.java:108)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
        at com.redhat.rhn.frontend.servlets.SessionFilter.doFilter(SessionFilter.java:55)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
        at com.redhat.rhn.frontend.servlets.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingFilter.java:97)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
        at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:210)
        at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:172)
        at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
        at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:117)
        at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:108)
        at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:151)
        at org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:200)
        at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:283)
        at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:773)
        at org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:703)
        at org.apache.jk.common.ChannelSocket$SocketConnection.runIt(ChannelSocket.java:895)
        at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:685)
        at java.lang.Thread.run(Thread.java:735)
Caused by: java.lang.NullPointerException
        at com.redhat.rhn.frontend.action.systems.sdc.SystemOverviewAction.execute(SystemOverviewAction.java:75)
        at org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:431)
        ... 40 more
Comment 1 wes hayutin 2009-04-08 15:45:48 EDT
recreated:
1. create three orgs.
2. migrate from org 1 to org 2 to org 3

[root@grandprix audit]# migrate-system-profile --satellite grandprix.rhndev.redhat.com --systemId=1000010589 --to-org-id=64 -u admin -p dog8code
Error: redstone.xmlrpc.XmlRpcFault: unhandled internal exception: ORA-00001: unique constraint (RHNSAT.RHN_CONFCHAN_OID_LABEL_TYPE_UQ) violated
ORA-06512: at "RHNSAT.RHN_CONFIG", line 180
ORA-06512: at line 1
Comment 2 wes hayutin 2009-04-14 09:31:43 EDT
Created attachment 339487 [details]
additional tracebacks from clicking on broken migrated profile
Comment 3 Brad Buckingham 2009-04-14 18:48:52 EDT
master git commit: 6c12b5c99efb914a981ed57b7da3c36f147f0670
vader git commit: 500f50721a068f459a95bcb6e9226c585cd3ed5a
Comment 4 Brad Buckingham 2009-04-27 08:26:56 EDT
mass move to ON_QA
Comment 5 Preethi Thomas 2009-05-28 09:40:41 EDT
verified
ISO: Satellite-5.3.0-RHEL4-re20090521.1-i386-embedded-oracle.iso
Comment 7 Brandon Perkins 2009-09-10 15:48:54 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.