Bug 494683 - autobackup option of vgchange doesn't appear to work
autobackup option of vgchange doesn't appear to work
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: lvm2 (Show other bugs)
5.3
All Linux
low Severity low
: rc
: ---
Assigned To: Peter Rajnoha
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-07 14:51 EDT by Corey Marthaler
Modified: 2010-01-11 22:56 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-06 08:42:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Marthaler 2009-04-07 14:51:07 EDT
Description of problem:
[root@grant-01 ~]# vgs
  VG         #PV #LV #SN Attr   VSize   VFree  
  VolGroup00   1   2   0 wz--n-  74.38G      0 
  grant        1   1   0 wz--nc 272.46G 272.36G

[root@grant-01 ~]# vgchange -Ay grant
  One of -a, -c, -l, -p, -s, -x, --uuid, --alloc, --addtag or --deltag required
  Run `vgchange --help' for more information.
 
[root@grant-01 ~]# vgchange -A grant
  Invalid argument grant
  Error during parsing of command line.

[root@grant-01 ~]# vgchange -Ay
  One of -a, -c, -l, -p, -s, -x, --uuid, --alloc, --addtag or --deltag required
  Run `vgchange --help' for more information.

[root@grant-01 ~]# vgchange -Aya grant
  Invalid argument ya
  Error during parsing of command line.

[root@grant-01 ~]# vgchange -Aa grant
  Invalid argument a
  Error during parsing of command line.

[root@grant-01 ~]# vgchange -Ay -an grant
  -A option not necessary with -a option
  Run `vgchange --help' for more information.

[root@grant-01 ~]# vgchange -A grant
  Invalid argument grant
  Error during parsing of command line.

[root@grant-01 ~]# vgchange -Ay grant
  One of -a, -c, -l, -p, -s, -x, --uuid, --alloc, --addtag or --deltag required
  Run `vgchange --help' for more information.

[root@grant-01 ~]# vgchange -An grant
  One of -a, -c, -l, -p, -s, -x, --uuid, --alloc, --addtag or --deltag required
  Run `vgchange --help' for more information.

[root@grant-01 ~]# vgchange --autoconfig grant
vgchange: unrecognized option `--autoconfig'
  Error during parsing of command line.

[root@grant-01 ~]# vgchange --autoconfig y grant
vgchange: unrecognized option `--autoconfig'
  Error during parsing of command line.

[root@grant-01 ~]# vgchange --autoconfig -y grant
vgchange: unrecognized option `--autoconfig'
  Error during parsing of command line.

[root@grant-01 ~]# vgchange --autoconfigy grant
vgchange: unrecognized option `--autoconfigy'
  Error during parsing of command line.


Version-Release number of selected component (if applicable):
lvm2-2.02.40-6.el5
Comment 1 Peter Rajnoha 2009-05-06 08:42:56 EDT
This option is used in conjunction with the other options when making changes. Since autobackup option is not contained within metadata, we have to define this option for every change we make (default is "y"). It can't be defined globally for any future changes in a separate way, so this is not a bug. Maybe we should add a note to man so it's less confusing. "--autoconfig" was meant to be "--autobackup", I guess...

Note You need to log in before you can comment on or make changes to this bug.