Bug 494713 - GFS2: gfs2_edit should be moved from /sbin/ to /usr/sbin/
GFS2: gfs2_edit should be moved from /sbin/ to /usr/sbin/
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: cluster (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Fabio Massimo Di Nitto
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-07 17:00 EDT by Nate Straz
Modified: 2016-04-26 09:38 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-21 13:55:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nate Straz 2009-04-07 17:00:02 EDT
Description of problem:

Found during TPS tests, /sbin/gfs2_edit depends on a library in /usr.

gfs2_edit should probably be moved to /usr/sbin.

=== SharedLibTest =====================
gfs2-utils-0.1.53-1.el5_3.2.i386: /sbin/gfs2_edit relies on libs in /usr: libncurses.so.5 => /usr/lib/libncurses.so.5 (0x006fc000) 
SharedLibTest: 11 regular binaries and 11 debug files were found.
Checked 13 of these 22 ELF objects, and 1 error was found.
Unless otherwise reported, any unchecked objects are part of debuginfo and may be ignored.
TPSRESULT: SharedLibTest Returning: FAIL

Version-Release number of selected component (if applicable):
gfs2-utils-0.1.53-1.el5_3.2

How reproducible:
100%

Steps to Reproduce:
1. ldd /sbin/gfs2_edit | grep /usr
  
Actual results:


Expected results:


Additional info:
Comment 1 Robert Peterson 2009-04-08 10:57:14 EDT
I have no problem moving it to /usr/bin.  My concern is what happens
to people who currently have it located in /sbin?  The Makefile should
probably also make sure it gets deleted from /sbin.
Comment 2 Robert Peterson 2009-04-21 10:30:20 EDT
I had a discussion with Chris Feist and Nate Straz and we decided it
was a bad idea to move the binary mid-release.  Therefore, I'm
deferring this bug to RHEL6.
Comment 3 Robert Peterson 2009-04-21 13:55:37 EDT
Spoke with Fabio, and it turns out that in F11, gfs2_edit does
reside in /usr/sbin.  So the issue here for RHEL6 is more that
some of the others, such as fsck.gfs2, need to be moved to /sbin.
Fabio is going to take care of that upstream, so this should be
a non-issue for RHEL6.  Closing it as NEXTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.