Bug 494764 - OpenEXR-devel doesn't state ilmbase-devel requirement
OpenEXR-devel doesn't state ilmbase-devel requirement
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: OpenEXR (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-07 22:26 EDT by Joel
Modified: 2009-04-08 08:56 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-08 08:56:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joel 2009-04-07 22:26:16 EDT
pkg-config --libs OpenEXR fails becase ilmbase pkg-config fails

yum install openexr-devel should bring in ilmbase-devel

Please check all fedora releases
Comment 1 Rex Dieter 2009-04-07 23:02:11 EDT
ilmbase-devel isn't needed really, and wasn't due to Requires.private... until pkgconfig behavior wrt Requires.private changed recently.
Comment 2 Rex Dieter 2009-04-07 23:06:06 EDT
I take that back, OpenEXR-devel already includes
Requires: ilmbase-devel

What makes you think otherwise?
Comment 3 Joel 2009-04-07 23:39:12 EDT
Because I did yum install OpenEXR-devel and pkg-config --libs OpenEXR errorred out and then I did yum install ilmbase-devel and then it worked?

Did you try uninstalling openexr and ilmbase and then installing openexer-devel and then doing the pkg-config?

On Fedora 9?
Comment 4 Joel 2009-04-08 00:04:52 EDT
Ok.  I repeated the process and it didn't reproduce.  So strange.  I guess this can be closed.
Comment 5 Rex Dieter 2009-04-08 08:56:40 EDT
ok, wierd.  :\

Note You need to log in before you can comment on or make changes to this bug.