Bug 494770 - Cannot change connection settings
Cannot change connection settings
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-07 23:12 EDT by Braden McDaniel
Modified: 2009-04-09 09:39 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-09 04:41:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Network Connections dialog screen shot (26.21 KB, image/png)
2009-04-09 00:30 EDT, Braden McDaniel
no flags Details

  None (edit)
Description Braden McDaniel 2009-04-07 23:12:49 EDT
Description of problem:
NetworkManager won't let me change any connection settings. When I click on "Edit" for a connection, all the buttons and fields on all the tabs are grayed out.

Version-Release number of selected component (if applicable):
0.7.0.99-5.git20090326.fc10
Comment 1 Niels Haase 2009-04-08 03:12:11 EDT
Reporter, could you please say us if you have the problem only on wireless or wired network tabs or both?. If you try to add an Network, are there also all buttons grayed out? Thank you.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Braden McDaniel 2009-04-08 03:25:51 EDT
It's just the wired network tab.

The buttons are not grayed out when I go to add a connection.
Comment 3 Dan Williams 2009-04-08 21:28:41 EDT
The connection you are attempting to edit is a "system" connection, which is read-only at this time.  You can create a new connection with the "Add" button and configure that as you like.  Let me know if that doesn't work for you.
Comment 4 Braden McDaniel 2009-04-08 21:59:00 EDT
In that case, NetworkManager has erroneously configured the "system" connections to use DHCP. Is there really no way to correct this? 

I am able to add another connection; however, I have not found a way to make NetworkManager use the added connection by default. NetworkManager reverts to using one of the "system" connections when the machine is restarted.
Comment 5 Braden McDaniel 2009-04-08 21:59:39 EDT
Reopening. There is definitely a bug here; though I'm no longer sure exactly what it is.
Comment 6 Dan Williams 2009-04-08 22:07:52 EDT
Does it look like this?  Can you post a screenshot of your "wired" tab?

http://people.redhat.com/dcbw/nm-ce-wired.png
Comment 7 Braden McDaniel 2009-04-09 00:30:05 EDT
Created attachment 338856 [details]
Network Connections dialog screen shot

It looks like this.

This machine has two wired NICs; which apparently correspond to "System eth0" and "System eth2".  (Why "eth2" and not "eth1", I'm not sure.)  Upon startup, NetworkManager always connects using "System eth0".  Both "System eth0" and "System eth2" are configured to use DHCP and there appears to be no way to change that.

"Wired connection 1" is the connection I added.  I am able to configure it as I like.  However, I had to set it up using the same MAC address as "System eth0".  I don't know if that's a bad thing or not; but it feels funny.

From 10,000 ft, the problem here is this: NetworkManager starts up using a DHCP connection when it should be using a static IP.
Comment 8 Braden McDaniel 2009-04-09 04:24:54 EDT
Okay... Part of the issue here has been a lack of understanding on my part regarding the relationship between NetworkManager and the "classical" network interface scripts (configured by system-config-network).  I had been under the impression that these were two separate worlds--and that appeared to be the case until relatively recently.

So now, I take it, the "system" connections are configured by system-config-network; and NetworkManager is currently incapable of modifying these interfaces (caveat bug 495027).

So if this is, in fact, "working as intended", I guess we're done here. Though clearly the current NetworkManager/system-config-network dichotomy has *serious* usability flaws.
Comment 9 Dan Williams 2009-04-09 09:39:11 EDT
(In reply to comment #8)
> Okay... Part of the issue here has been a lack of understanding on my part
> regarding the relationship between NetworkManager and the "classical" network
> interface scripts (configured by system-config-network).  I had been under the
> impression that these were two separate worlds--and that appeared to be the
> case until relatively recently.
> 
> So now, I take it, the "system" connections are configured by
> system-config-network; and NetworkManager is currently incapable of modifying
> these interfaces (caveat bug 495027).

Currently, but that capability is planned for F11 and is being worked on in a branch upstream:

http://cgit.freedesktop.org/NetworkManager/NetworkManager/log/?h=ifcfg-rh-write

> So if this is, in fact, "working as intended", I guess we're done here. Though
> clearly the current NetworkManager/system-config-network dichotomy has
> *serious* usability flaws.  

Yes, it does; those are actively being rectified.

Note You need to log in before you can comment on or make changes to this bug.