Bug 494774 - [kbabel] XIM gives random text insertion from input method
[kbabel] XIM gives random text insertion from input method
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: scim (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: Peng Wu
QE Internationalization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-07 23:40 EDT by Noriko Mizumoto
Modified: 2014-01-21 02:02 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 02:02:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Noriko Mizumoto 2009-04-07 23:40:22 EDT
Description of problem:
When typing Japanese, displaying the candidates, choosing the candidate to suit and enter to decide, then it appears unexpected place randomly regardless the position of the cursor.

Version-Release number of selected component (if applicable):
RHEL5.3 and Kbabel1.11.4 

How reproducible:
Always it happens after first successful entering.

Actual results:
Japanese character(s) decided appears unexpected place randomly.

Expected results:
Japanese character(s) decided should appear where the cursor is positioned.

Additional info:
Kbabel1.11.4 works correct manner on RHEL5.2.
Comment 1 Jens Petersen 2009-04-08 00:07:41 EDT
Noriko, can you test with the U2 scim and scim-bridge packages
to see if it is a scim regression?
Comment 2 Jens Petersen 2009-04-08 00:08:29 EDT
A screenshot might be good too if available.
Comment 4 Akira TAGOH 2009-04-08 01:55:22 EDT
any testcases to reproduce that? just tried with the following packages and steps but it works for me:

scim-1.4.4-41.el5
scim-bridge-0.4.5-8.el5
qt-3.3.6-23.el5
kdelibs-3.5.4-18.el5
kdesdk-3.5.4-3.el5
kdebase-3.5.4-19.el5

1. msgunfmt /usr/share/locale/ja/LC_MESSAGES/im-chooser.mo > ja.po
2. run kbabel and open ja.po
3. remove a translation once and type again

for more information:
$ echo $XMODIFIERS
@im=SCIM
Comment 5 Noriko Mizumoto 2009-04-08 02:10:01 EDT
(Marco from helpdesk added.)

Marco, could you mind to help reproducing the problem?

(In reply to comment #4)
> any testcases to reproduce that? just tried with the following packages and
> steps but it works for me:
> 
> scim-1.4.4-41.el5
> scim-bridge-0.4.5-8.el5
> qt-3.3.6-23.el5
> kdelibs-3.5.4-18.el5
> kdesdk-3.5.4-3.el5
> kdebase-3.5.4-19.el5
> 
> 1. msgunfmt /usr/share/locale/ja/LC_MESSAGES/im-chooser.mo > ja.po
> 2. run kbabel and open ja.po
> 3. remove a translation once and type again
> 
> for more information:
> $ echo $XMODIFIERS
> @im=SCIM
Comment 6 Marco Grigull 2009-04-15 21:04:06 EDT
Dear Noriko, Team,

I am npot able to reproduce the issue without your help.

My laptop is here in the BNE office which has been configured as per the troubled setup.  Please let me know whom it needs to be demoed to.

If need be, I could install some desktop recording software, which could visually capture the problem though I would still need your input for this.  I could also make a sysreport snapshot of that system so that the package information is available.

Regards,
Marco
Comment 7 Jens Petersen 2009-04-16 00:22:43 EDT
This is a known issue with XIM and kbabel.

You need to use scim-qtimm for correct input commits in kbabel.
Comment 8 Akira TAGOH 2009-04-16 07:19:30 EDT
a known issue? hmm, tried this again with QT_IM_MODULE=xim or without scim-qtimm though, it works for me.

Anyway please give us a testcase to reproduce this.
Comment 9 Akira TAGOH 2009-04-17 06:27:28 EDT
Okay, I can confirmed here. well, apparently it looks like not updating the caret position when moving cursor. so always inserting a text after the last caret position where committed last time. we need to narrow down which qt or scim is causing.

for a workaround, it works as expected after turning off/on IM.
Comment 10 Akira TAGOH 2009-05-28 10:27:40 EDT
Update:

I have tested this issue again with kinput2 and it works fine. apparently this issue happens only with scim and Qt applications.
Comment 11 Peng Wu 2013-03-26 03:18:53 EDT
Could this be work around by disable "Embed Preedit String into clinet window" option in the scim-setup dialog?

The option is in the "FrontEnd" => "Global Setup" page.
Comment 12 Jens Petersen 2014-01-21 01:59:35 EST
I suspect the reporter is no longer using RHEL5...

Anyone able to test the workaround?
Comment 13 Peng Wu 2014-01-21 02:02:25 EST
Long time without response, close bug.

Note You need to log in before you can comment on or make changes to this bug.