Bug 494787 - "Unable to mount location" org.freedesktop.devicekit.disks.filesystem-mount-system-internal auth_admin
"Unable to mount location" org.freedesktop.devicekit.disks.filesystem-mount-s...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-disk-utility (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
: 494972 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-08 00:51 EDT by sangu
Modified: 2010-03-16 23:20 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-08 12:13:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sangu 2009-04-08 00:51:05 EDT
Description of problem:
Click Internal Partition in Computer:// ->
Popup Dialog "Unable to mount location" org.freedesktop.devicekit.disks.filesystem-mount-system-internal auth_admin 

Version-Release number of selected component (if applicable):
004-0.4.20090406git.fc11

How reproducible:
always

Steps to Reproduce:
1. Click Computer:// in Nautilus
2. Click Storage icon ( Unremovable internal partition )
3.
  
Actual results:


Expected results:


Additional info:
gvfs-smb-1.2.1-1.fc11.x86_64
gvfs-archive-1.2.1-1.fc11.x86_64
gvfs-fuse-1.2.1-1.fc11.x86_64
gvfs-gphoto2-1.2.1-1.fc11.x86_64
gvfs-obexftp-1.2.1-1.fc11.x86_64
gvfs-1.2.1-1.fc11.x86_64
nautilus-2.26.1-2.fc11.x86_64
Comment 1 Matthias Clasen 2009-04-08 09:04:46 EDT
What kind of partition is that ? I'm pretty sure internal partitions are not supposed to show up in computer.

That being said, I am getting

mount: only root can mount /dev/sda3 on /other

too, when trying to mount an internal partition in palimpsest. And this is _after_ entering the root password in the PK dialog...
Comment 2 sangu 2009-04-08 10:23:51 EDT
(In reply to comment #1)
> What kind of partition is that ?
Fat32 , NTFS and another linux partition (ext3)

> I'm pretty sure internal partitions are not
> supposed to show up in computer.
> 
> That being said, I am getting
> 
> mount: only root can mount /dev/sda3 on /other
> 
> too, when trying to mount an internal partition in palimpsest. And this is
> _after_ entering the root password in the PK dialog...  


hmm, strange.
When clicking partition icons in Computer://, error dialog popups.
When trying to mount in palimpsest, Pk dialog popups. mount works well.

Question> Is this feature? only palimpse can mount internal partitions.

# fdisk -l /dev/sda

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x0a480a47

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1        3824    30716248+   7  HPFS/NTFS
/dev/sda2            3825       19456   125564040    f  W95 Ext'd (LBA)
/dev/sda5            3825        7648    30716248+   b  W95 FAT32
/dev/sda6            7649       11472    30716248+   b  W95 FAT32
/dev/sda7           11473       15297    30724281    b  W95 FAT32
/dev/sda8           15298       15425     1028128+  82  Linux swap / Solaris
/dev/sda9           15426       19456    32378976   83  Linux

$ fdisk -l /dev/sdb

Disk /dev/sdb: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x6ee17eed

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *           1        6375    51200000    7  HPFS/NTFS
/dev/sdb2            6375       53153   375743488    7  HPFS/NTFS
/dev/sdb3           53154       60801    61432560   83  Linux

nautilus-2.26.1-2.fc11
Comment 3 David Zeuthen 2009-04-08 11:35:01 EDT
(In reply to comment #1)
> What kind of partition is that ? I'm pretty sure internal partitions are not
> supposed to show up in computer.

They are. The bug is with the GVfs volume monitor not doing the PolicyKit dialog dance correctly. I will look into it.

> That being said, I am getting
> 
> mount: only root can mount /dev/sda3 on /other
> 
> too, when trying to mount an internal partition in palimpsest. And this is
> _after_ entering the root password in the PK dialog...  

I bet that you have an entry for /dev/sda3 (or a symlink, LABEL= or UUID= alias) in /etc/fstab for /dev/sda3. Is that about right?

Ideally we shouldn't have a PolicyKit authentication dialog here but that is a separate bug: One fix is to make the client check whether the device is referenced in /etc/fstab. Because the way it works is that if a device to be mounted via FilesystemMount() is referenced in /etc/fstab we fall back to mounting as the calling user. See

http://hal.freedesktop.org/docs/DeviceKit-disks/Device.html#Device.FilesystemMount

We do this to avoid circumventing the system policy defined by the /etc/fstab file.

However, another (and better) fix is to just wait for the new PolicyKit release where clients don't have to know anything about PolicyKit.
Comment 4 Matthias Clasen 2009-04-08 11:37:00 EDT
> I bet that you have an entry for /dev/sda3 (or a symlink, LABEL= or UUID=
> alias) in /etc/fstab for /dev/sda3. Is that about right?

Yes, that is right. 

I guess I am just complaining that allowing to unmount, but then not to mount again is broken.
Comment 5 David Zeuthen 2009-04-08 11:52:31 EDT
(In reply to comment #4)
> > I bet that you have an entry for /dev/sda3 (or a symlink, LABEL= or UUID=
> > alias) in /etc/fstab for /dev/sda3. Is that about right?
> 
> Yes, that is right. 
> 
> I guess I am just complaining that allowing to unmount, but then not to mount
> again is broken.  

Huh? That again sounds like a separate bug. My guess is that the device is mounted at boot (by the boot scripts) and you are then allowed to unmount it (with authorization)? Do you have an authorization for the org.freedesktop.devicekit.disks.filesystem-unmount-others action?
Comment 6 Matthias Clasen 2009-04-08 11:58:07 EDT
Another problem I notice is that devicekit somehow manages to nuke the mountpoint after such a failed mount attempt. I have to mkdir /other before I can mount it again on the commandline.
Comment 7 Matthias Clasen 2009-04-08 11:59:52 EDT
To answer the question in comment 5: yes, unmounting /other does ask for the root password (as per the configured policy), and then it succeeds. Mounting it again asks for the root password too (as it should), and then fails.
Comment 8 David Zeuthen 2009-04-08 12:13:20 EDT
(In reply to comment #3)
> (In reply to comment #1)
> > What kind of partition is that ? I'm pretty sure internal partitions are not
> > supposed to show up in computer.
> 
> They are. The bug is with the GVfs volume monitor not doing the PolicyKit
> dialog dance correctly. I will look into it.

Should be fixed in gnome-disk-utility-0.3-0.2.20090406git.fc11.

http://koji.fedoraproject.org/koji/taskinfo?taskID=1285631
Comment 9 David Zeuthen 2009-04-08 13:00:03 EDT
(In reply to comment #6)
> Another problem I notice is that devicekit somehow manages to nuke the
> mountpoint after such a failed mount attempt. I have to mkdir /other before I
> can mount it again on the commandline.  

I was able to reproduce this but only sometimes - were you able to reproduce it all the time? Either way, it should be fixed with this commit

http://cgit.freedesktop.org/DeviceKit/DeviceKit-disks/commit/?id=73fbbdffa6d87d42e53f001550d7aa779d97580c

Please check if that works for you.
Comment 10 David Zeuthen 2009-04-08 17:21:00 EDT
*** Bug 494972 has been marked as a duplicate of this bug. ***
Comment 11 bugfinder 2010-03-16 23:20:35 EDT
I have the same problem when I try to mount my iPod.

org.freedesktop.PolicyKit.Error.NotAuthorized: org.freedesktop.devicekit.disks.filesystem-mount no

Note You need to log in before you can comment on or make changes to this bug.