Bug 494797 - Screen flickers after enabling desktop effects on kde-4.2.2
Screen flickers after enabling desktop effects on kde-4.2.2
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-08 03:00 EDT by Joshua Covington
Modified: 2018-04-11 05:05 EDT (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-21 20:20:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log - total freeze (35.66 KB, text/plain)
2009-04-11 09:04 EDT, Joshua Covington
no flags Details
customized xorg.conf (1.97 KB, application/octet-stream)
2009-04-11 09:15 EDT, Joshua Covington
no flags Details

  None (edit)
Description Joshua Covington 2009-04-08 03:00:45 EDT
Description of problem:
After updating to the lastest kde4.2.2 I cannot enable the desktop effects. After enabling them the screen starts flickering and thus is useless. kde4.2.1 (f11) works fine though. and kde4.2.2 on f9 works fine, too. gnome (f11) doesn't have this problem. without the effect everything works  well.


Version-Release number of selected component (if applicable):
kdebase-4.2.2-2.f11.x86_64
xorg-x11-drv-ati-6.12.1-8.f11.x86_64
xorg-x11-server-Xorg-1.6.0-17.fc11.x86_64


How reproducible:
update to kde4.2.2
  

Actual results:
The screen start flickering as though it is kind of a drop-down menu. only parts of it are shown. Other parts appear when moving the mouse on them and then disapper again. the "magic-lamp" effect seems to work fine, even with partly-hidden windows.


Expected results:
desktop effekt on kde4.2.2 works fine


Additional info:
All these were tested with livecds as of 07.04.2009. the lastest gnome and kde4.2.1 work fine with desktop effect enabled. And my F9 also works with desktop effects.
Comment 1 Rex Dieter 2009-04-08 08:57:47 EDT
Usually indicates video driver issue.  What video hw/driver are you using?
Comment 2 Joshua Covington 2009-04-08 09:43:09 EDT
This is what I thought, but gnome doesn't have this problem. And on my F9 everything is fine. I have radeon rs482 (http://www.smolts.org/client/show/pub_1ea45a8d-e70f-424f-aeab-c04eaec10b6f) with the xorg-x11-drv-ati-6.12.1-8.fc11.
Comment 3 Kevin Kofler 2009-04-08 13:33:48 EDT
> gnome doesn't have this problem

That doesn't prove anything, video driver problems always only trigger under certain conditions, so only with certain applications.
Comment 4 Matěj Cepl 2009-04-10 11:00:45 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 5 Joshua Covington 2009-04-11 09:04:50 EDT
Created attachment 339179 [details]
Xorg.0.log - total freeze

Here is the xorg.0.log. When enabling the desktop effects in kde and starting firefox the whole system freezes. Form the last line in the file I see that the log file doesn't get updated when the system froze.
Comment 6 Joshua Covington 2009-04-11 09:15:10 EDT
Created attachment 339180 [details]
customized xorg.conf

my custmozed xorg.conf file. I haven't changed it since f8 an it's worked without problems. maybe most of the options aren't needed with f11 or are enabled by default in 6.12.1 but I haven't changed the file. The DRI and Extention sections are from the days before xorg-x11-drv-ati-0.6.9.

installed:
xorg-x11-drv-ati-6.12.1-7.f11.x86_64
mesa-7.4.0-8
xorg-x11-server-1.6.0-17
libdrm-2.6.4-3
kernel-2.6.29.1-54
kde-4.2.2
Comment 7 Robert Szalai 2009-04-30 07:52:20 EDT
Hi there,

the same thing happens on Macbook Pro 2,1 with ATI X1600 mobility. I turn on desktop effects, the screen start to flicker and I can only see the borders of the plasma widgets. If I move the mouse over the windows some parts get revealed other parts of the window disappear in a seemingly random fashion. I've upgraded to the latest kernel, mesa and xorg-x11-drv-ati in koji, but things got even worse, now video playback got broken, too.

Note that desktop effects with KDE 4.2.2 work in Arch linux where no KMS is enabled. The driver version is the same, but possibly without custom patches.

Let me know if you need more information, it would be nice to have a fix as this is the last thing that prevents me using Fedora, which is great otherwise.
Comment 8 Bug Zapper 2009-06-09 09:28:25 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Dave Airlie 2009-06-13 02:13:08 EDT
please try mesa 7.6-0.1 from updates-testing when it lands, or grab it from koji.
Comment 10 Imre Szell 2009-06-24 05:56:57 EDT
i had similar problem as described above (i have xorg 1.6.1.901-1, kde 4.2.3 xorg-ati driver 6.12.2-14 versions installed on my fedora 11, with an integrated ati radeon xpress 200 adapter). i upgraded to mesa 7.6-0.1 from the test repository, and the problem is gone kde works with the enabled effects.
Comment 11 Imre Szell 2009-06-24 05:58:13 EDT
i had similar problem as described above (i have xorg 1.6.1.901-1, kde 4.2.3 xorg-ati driver 6.12.2-14 versions installed on my fedora 11, with an integrated ati radeon xpress 200 adapter). i upgraded to mesa 7.6-0.1 from the test repository, and the problem is gone, kde works fine with the enabled desktop effects.
Comment 12 Robert Szalai 2009-06-24 06:13:12 EDT
Hi Imre, is the performace OK? For me with the radeon X1600 (M56) the performance compared to non KMS/DRI1 is just pathetic, basically unusable. Also with this setup Qt 4.5.1 crashes horribly while it works just fine on other Linuxes.
Comment 13 Imre Szell 2009-06-24 06:26:29 EDT
hi robert, unfortunately no. i wouldn't say it is unusable, but it is slow.
Comment 14 CJ 2009-06-26 04:59:22 EDT
A mesa upgrade has not resolved this issue for me.

Enabling desktop effects causes minor flickering on the screen. Performing any action on a window then causes massive amounts of flickering making the screen unusable.

mesa-libGLU-7.6-0.1.fc11.x86_64
mesa-dri-drivers-7.6-0.1.fc11.x86_64
mesa-libGL-7.6-0.1.fc11.x86_64
xorg-x11-drv-ati-6.12.2-14.fc11.x86_64

VGA compatible controller: ATI Technologies Inc RV516 [Radeon X1300/X1550 Series]

This ONLY occurs if I have dual-heads running.
If I don't enable and extend onto the second monitor ( via xrandr ) then the issue does not occur.
Comment 15 CJ 2009-07-02 10:45:58 EDT
(In reply to comment #14)
> A mesa upgrade has not resolved this issue for me.
> 
> Enabling desktop effects causes minor flickering on the screen. Performing any
> action on a window then causes massive amounts of flickering making the screen
> unusable.
> 
> mesa-libGLU-7.6-0.1.fc11.x86_64
> mesa-dri-drivers-7.6-0.1.fc11.x86_64
> mesa-libGL-7.6-0.1.fc11.x86_64
> xorg-x11-drv-ati-6.12.2-14.fc11.x86_64
> 
> VGA compatible controller: ATI Technologies Inc RV516 [Radeon X1300/X1550
> Series]
> 
> This ONLY occurs if I have dual-heads running.
> If I don't enable and extend onto the second monitor ( via xrandr ) then the
> issue does not occur.  

Edit : This problem was resolved by using a new pair of monitors. I can only conclude that this was due to a vsync issue or similar, although the previous F10 install had no problems.

For me, this bug is fixed with the mesa updates.
Comment 16 Kevin Kofler 2009-07-02 11:25:03 EDT
OK, can _anybody_ still reproduce this? If not, I suggest we just close this as WORKSFORME lacking precise knowledge what exactly fixed it.
Comment 17 Robert Szalai 2009-07-02 11:40:47 EDT
I agree with closing this. Last time i tried I couldn't reproduce these specific symptoms with the new mesa package.
Comment 18 Steven M. Parrish 2009-07-21 20:20:45 EDT
Per Kevin and Robert's remarks closing this as WORKSFORME.  Please feel free to reopen if the problem returns.

-- 
Steven M. Parrish - KDE Triage Master
                  - PackageKit Triager
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.