Bug 494805 - installing the obsoleter which requires something fails
installing the obsoleter which requires something fails
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.8
All Linux
medium Severity medium
: rc
: ---
Assigned To: Pradeep Kilambi
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-08 03:41 EDT by Jan Hutař
Modified: 2010-05-05 07:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-05 07:08:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2009-04-08 03:41:44 EDT
Description of problem:
There is on the system:
  ecj-2.1.3-5.ia64
  <no java on the system (only packages like gcc-java, java-1.4.2-gcj-compat,
    gcc4-java installed)>
And in the channels there is (on Stage):
  rhel-4-as-ia64-rhaps-2:
    eclipse-ecj-3.0.2-8.ia64
      - reqiures: java >= 1.4.2
      - obsoletes: ecj
      - provides: ecj
  rhel-ia64-as-4-extras:
    java-1.4.2-bea-1.4.2.16-1jpp.4.el4.ia64
    java-1.4.2-bea-console-1.4.2.08-1jpp_42rh.ia64
    java-1.4.2-bea-devel-1.4.2.16-1jpp.4.el4.ia64
    java-1.4.2-bea-jdbc-1.4.2.16-1jpp.4.el4.ia64
    java-1.4.2-bea-uninstall-1.4.2.16-1jpp.7.el4.ia64
    java-1.4.2-ibm-1.4.2.12-1jpp.1.el4.ia64
    java-1.4.2-ibm-demo-1.4.2.12-1jpp.1.el4.ia64
    java-1.4.2-ibm-devel-1.4.2.12-1jpp.1.el4.ia64
    java-1.4.2-ibm-src-1.4.2.12-1jpp.1.el4.ia64
    java-1.5.0-bea-1.5.0.14-1jpp.2.el4.ia64
    java-1.5.0-bea-console-1.5.0.03-1jpp_9rh.ia64
    java-1.5.0-bea-demo-1.5.0.14-1jpp.2.el4.ia64
    java-1.5.0-bea-devel-1.5.0.14-1jpp.2.el4.ia64
    java-1.5.0-bea-jdbc-1.5.0.14-1jpp.2.el4.ia64
    java-1.5.0-bea-src-1.5.0.14-1jpp.2.el4.ia64
    java-1.5.0-bea-uninstall-1.5.0.14-1jpp.5.el4.ia64
And when I try to install eclipse-ecj, it fails.


Version-Release number of selected component (if applicable):
up2date-4.8.1-30.el4.ia64
rhnlib-2.1.4-5.el4.noarch
rpm-4.3.3-26_nonptl.ia64


How reproducible:
always


Steps to Reproduce:
1. # up2date -i eclipse-ecj / up2date -u eclipse-ecj


Actual results:
Fetching rpm headers...
########################################

Name                                    Version              Rel               Arch
----------------------------------------------------------------------------------------
eclipse-ecj                             3.0.2               8                   ia64  


Testing package set / solving RPM inter-dependencies...
There was a package dependency problem. The message was:

Unresolvable chain of dependencies:
eclipse-ecj-3.0.2-8                      requires java >= 1.4.2 


The following packages were added to your selection to satisfy dependencies:
Package                                Required by
----------------------------------------------------------------------------


Expected results:
should work


Additional info:
Could this be connected to the bug 468006?

Command:
# up2date -u eclipse-ecj java-1.4.2-ibm
works as expected.
Comment 1 Radek Bíba 2009-04-08 04:06:50 EDT
I might add that java-1.4.2-ibm, which is available in one of the channels the system is subscribed to, does provide java = 1.4.2. On the other hand, java-1.4.2-bea may be the cause of the problem. It also provides java = 1.4.2, but this package is obsoleted by java-1.4.2-bea-uninstall, which also conflicts with java-1.4.2-bea.
Comment 2 RHEL Product and Program Management 2010-05-05 07:08:25 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.