Bug 494831 - file displays "for GNU/Linux 2.6.9" message twice
file displays "for GNU/Linux 2.6.9" message twice
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: file (Show other bugs)
5.3
All Linux
low Severity low
: rc
: ---
Assigned To: Jan Kaluža
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-08 05:43 EDT by Milos Malik
Modified: 2012-10-31 05:22 EDT (History)
2 users (show)

See Also:
Fixed In Version: file-4.17-17
Doc Type: Bug Fix
Doc Text:
Cause: Note field stored in ELF binaries was processed twice. Consequence: File output contained "for GNU/Linux ..." message twice Fix: Note field is processed only once. Result: "for GNU/Linux ..." message is printed only once.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-21 00:45:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
a patch to solve this issue (6.07 KB, patch)
2009-10-05 10:35 EDT, Daniel Novotny
no flags Details | Diff

  None (edit)
Description Milos Malik 2009-04-08 05:43:51 EDT
Description of problem:
The 'file' utility duplicates one part of its output.

Version-Release number of selected component (if applicable):
file-4.17-15
dump-debuginfo-0.4b41-4.el5

How reproducible:
always

Steps to Reproduce:
# /usr/bin/file /usr/lib/debug/sbin/rmt.debug 
/usr/lib/debug/sbin/rmt.debug: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), for GNU/Linux 2.6.9, statically linked, for GNU/Linux 2.6.9, not stripped
# echo $?
0
  
Actual results:
the text "for GNU/Linux 2.6.9" is displayed twice

Expected results:
the text "for GNU/Linux 2.6.9" is displayed once

Additional info:
Comment 1 RHEL Product and Program Management 2009-04-08 05:46:54 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 2 Daniel Novotny 2009-10-05 10:35:52 EDT
Created attachment 363680 [details]
a patch to solve this issue

a few adjustments in readelf.c, backported from new upstream version, which behaves correctly
Comment 3 RHEL Product and Program Management 2009-11-06 13:53:23 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 6 RHEL Product and Program Management 2010-08-09 14:46:35 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 8 RHEL Product and Program Management 2011-05-31 09:55:37 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 13 Jan Kaluža 2012-01-05 04:33:40 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause: Note field stored in ELF binaries was processed twice.

Consequence: File output contained "for GNU/Linux ..." message twice

Fix: Note field is processed only once.

Result: "for GNU/Linux ..." message is printed only once.
Comment 14 errata-xmlrpc 2012-02-21 00:45:43 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0201.html

Note You need to log in before you can comment on or make changes to this bug.