Bug 494833 - Exception when deleting a partition
Exception when deleting a partition
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
anaconda_trace_hash:f8dcc1453b25aa3e6...
:
: 500862 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-08 05:46 EDT by Travers Carter
Modified: 2009-05-14 11:29 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-16 04:20:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (118.82 KB, text/plain)
2009-04-08 05:46 EDT, Travers Carter
no flags Details
Patch fixing this (3.09 KB, patch)
2009-04-08 08:54 EDT, Hans de Goede
no flags Details | Diff
Attached traceback automatically from anaconda. (378.38 KB, text/plain)
2009-04-16 12:41 EDT, Brian W. Masinick
no flags Details
Attached traceback automatically from anaconda. (239.21 KB, text/plain)
2009-04-17 13:21 EDT, Brian C. Lane
no flags Details
Attached traceback automatically from anaconda. (354.69 KB, text/plain)
2009-04-18 03:05 EDT, kiran
no flags Details
Attached traceback automatically from anaconda. (188.14 KB, text/plain)
2009-04-18 05:10 EDT, ENDOH takanao
no flags Details

  None (edit)
Description Travers Carter 2009-04-08 05:46:24 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.38 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/iw/partition_gui.py", line 931, in populate
    devname = "%s" % device.path
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1055, in refresh
    self.populate()
  File "/usr/lib/anaconda/iw/partition_gui.py", line 999, in deleteCB
    self.refresh(justRedraw=justRedraw)
AttributeError: 'NoneType' object has no attribute 'path'
Comment 1 Travers Carter 2009-04-08 05:46:33 EDT
Created attachment 338679 [details]
Attached traceback automatically from anaconda.
Comment 2 Travers Carter 2009-04-08 05:57:21 EDT
Anaconda crashed when trying to delete the partition sda6 from the "Create custom layout" option during installation.

The system is a Dell XPS M1210 laptop with a single HDD, the partition table is:

sda1 - primary vfat 47 Mb
sda2 - primary ntfs 70370 Mb
sda3 - extended 44053 Mb
  sda5 - logical vfat 2055 Mb
  sda6 - logical ext3 101 Mb (old /boot)
  sda7 - logical swap 2047 Mb
  sda8 - logical ext3 190771 (old /)
sda4 - primary ntfs 190771 Mb
Comment 3 Hans de Goede 2009-04-08 08:54:10 EDT
Created attachment 338702 [details]
Patch fixing this

Here is a patch fixing this, I'll commit this to git as soon as a fellow anaconda teammember has reviewed it.

Here is a description of the problem / patch:

When there are multiple (pre-existing) logical partitions and a logical
partition other then the last partition gets deleted, the number
of the partitions after it changes. Causing getDeviceByName, with the
name based on the new partition number (gotten through parted) to fail.

Specifically this causes a "'NoneType' object has no attribute 'path'"
exception in populate() in partition_gui.py . This patch fixes this by
updating all partitions names in doPartitioning.

Note that for this patch to help the following pyparted bug must also
be fixed: https://fedorahosted.org/pyparted/ticket/17
Comment 4 David Lehman 2009-04-08 11:21:28 EDT
I'm wondering if bug 493361 is also a result of the same behavior.
Comment 5 Hans de Goede 2009-04-08 12:08:40 EDT
(In reply to comment #4)
> I'm wondering if bug 493361 is also a result of the same behavior.  

Could be, we will need to ask the reporter to retest when a new anaconda is
build *AND* a new pyparted.
Comment 6 Travers Carter 2009-04-12 18:39:32 EDT
Looks like it's expected from the latest comment, but I can confirm that this bug is still present in Fedora-11-Snap1-x86_64-Live-KDE.
Comment 7 Hans de Goede 2009-04-16 04:20:40 EDT
Both the updated pyparted and a fixed anaconda are in rawhide now, closing this.
Comment 8 Brian W. Masinick 2009-04-16 12:41:51 EDT
Created attachment 339868 [details]
Attached traceback automatically from anaconda.
Comment 9 Brian C. Lane 2009-04-17 13:21:53 EDT
Created attachment 340049 [details]
Attached traceback automatically from anaconda.
Comment 10 kiran 2009-04-18 03:05:18 EDT
Created attachment 340130 [details]
Attached traceback automatically from anaconda.
Comment 11 ENDOH takanao 2009-04-18 05:10:01 EDT
Created attachment 340139 [details]
Attached traceback automatically from anaconda.
Comment 12 Chris Lumens 2009-05-14 11:29:36 EDT
*** Bug 500862 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.