Bug 494859 - failure of installation from Fedora 11 BETA LiveCD during disk partition
failure of installation from Fedora 11 BETA LiveCD during disk partition
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
11
All Linux
low Severity high
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-08 08:33 EDT by Martin Thain
Modified: 2009-12-05 15:27 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-05 15:27:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Installation Error txt from anaconda (194.78 KB, text/plain)
2009-04-08 08:33 EDT, Martin Thain
no flags Details
hardware profile - smoly (4.07 KB, text/plain)
2009-04-12 14:37 EDT, Martin Thain
no flags Details

  None (edit)
Description Martin Thain 2009-04-08 08:33:05 EDT
Created attachment 338701 [details]
Installation Error txt from anaconda

Description of problem:

I attempted to install fedora 11 BETA on a i386 PC from the live CD.
During disk partitioning anaconda advided that an error had occurred and to raise a ticket.

Version-Release number of selected component (if applicable):


How reproducible:
Attempt to install

Steps to Reproduce:
1.Boot PC from Live CD
2.Click on the install Icon from LIvecd
3. set up partitioning manually
  
Actual results:

Installation fails

Expected results:

Installation works

Additional info:
Comment 1 Martin Thain 2009-04-12 14:37:05 EDT
Created attachment 339257 [details]
hardware profile - smoly
Comment 2 Chris Lumens 2009-04-13 11:37:35 EDT
Looking at your exception log, I see that the problem appears to be /dev/sda2 does not yet exist when this code is run.  We have plenty of calls to udevadm settle, and yet the device node isn't showing up.  Looking further into your log, I see the following messages:

udevadm settle - timeout of 180 seconds reached, the event queue contains:
  /sys/devices/pci0000:00/0000:00:1f.1/host0/target0:0:0/0:0:0:0/block/sda/sda3 (1592)
  /sys/devices/pci0000:00/0000:00:1f.1/host0/target0:0:0/0:0:0:0/block/sda/sda2 (1591)
  /sys/devices/pci0000:00/0000:00:1f.1/host0/target0:0:0/0:0:0:0/block/sda/sda1 (1590)
  /sys/devices/pci0000:00/0000:00:1f.1/host0/target0:0:0/0:0:0:0/block/sda/sda3 (1589)
  /sys/devices/pci0000:00/0000:00:1f.1/host0/target0:0:0/0:0:0:0/block/sda/sda2 (1588)
  /sys/devices/pci0000:00/0000:00:1f.1/host0/target0:0:0/0:0:0:0/block/sda/sda1 (1587)
  /sys/devices/pci0000:00/0000:00:1f.1/host0/target0:0:0/0:0:0:0/block/sda/sda3 (1586)
  /sys/devices/pci0000:00/0000:00:1f.1/host0/target0:0:0/0:0:0:0/block/sda/sda2 (1585)
  /sys/devices/pci0000:00/0000:00:1f.1/host0/target0:0:0/0:0:0:0/block/sda/sda1 (1584)

Is 180 seconds seriously not long enough to make device nodes?
Comment 3 Harald Hoyer 2009-04-14 03:28:40 EDT
it is.. unless some rules start tools, which take so long
Comment 4 Harald Hoyer 2009-04-14 04:04:23 EDT
I really need a task list of what is going on ...
Comment 5 Bug Zapper 2009-06-09 09:29:29 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Martin Thain 2009-07-01 08:51:55 EDT
I'm not sure I can do anything regarding providing more information -
I feel there are two possible courses of action:-

1) Close this ticket as there has been so much work done on anaconda and installation in genral  since the ticket was opened.


2) Keep it open and retest when Fedora 12 goes onto test cycle when I will try the install again.
Comment 7 Martin Thain 2009-12-05 15:27:08 EST
Closing this - cannot reproduce in Fedora12

Note You need to log in before you can comment on or make changes to this bug.