Bug 494874 - Authconfig changes to support multistack GDM work
Authconfig changes to support multistack GDM work
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: authconfig (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-08 10:00 EDT by Ray Strode [halfline]
Modified: 2009-04-10 12:09 EDT (History)
1 user (show)

See Also:
Fixed In Version: authconfig-5.4.9-1.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-10 12:09:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
A proposed patch (11.41 KB, patch)
2009-04-08 10:01 EDT, Ray Strode [halfline]
no flags Details | Diff
PAM spec file changes (8.15 KB, patch)
2009-04-08 10:04 EDT, Ray Strode [halfline]
no flags Details | Diff

  None (edit)
Description Ray Strode [halfline] 2009-04-08 10:00:14 EDT
So one thing I'd like to get finished up before F11 is this feature:

http://fedoraproject.org/wiki/Features/MultiplePAMStacksInGDM

Part of this feature requires some changes to authconfig.  We need to write out separate files for distinct ways of interacting with the machine.  So for instance, we need a separate service configuration for smartcard authentication, one for fingerprint authentication, and one for password authentication.

We could ship these service files in GDM but then they wouldn't get updated when the user runs authconfig to e.g. enable Kerberos.
Comment 1 Ray Strode [halfline] 2009-04-08 10:01:56 EDT
Created attachment 338712 [details]
A proposed patch

This patch changes authconfig to write out the three new service files (and still keeps around the aggregate system-auth service file)
Comment 2 Ray Strode [halfline] 2009-04-08 10:04:28 EDT
Created attachment 338713 [details]
PAM spec file changes

In order for the authconfig changes in attachment 338712 [details] to work we need to update the PAM package to ship new initial service files.
Comment 3 Ray Strode [halfline] 2009-04-08 10:09:00 EDT
The GDM changes are being actively worked on here:

http://www.gnome.org/~halfline/gdm/

(on the multi-stack branch)

if you're interested.

The basic idea behind the change is rather than trying to aggregate 3 independent interactions into one conversation, we have 3 conversations running simultaneously, and GDM manages switching between them as appropriate.

This let's us, for instance, swipe our finger while asking for username.  It's also makes it a lot easier to upstream the GDM smartcard changes I did in RHEL5, since they now are in a plugin instead of bolted on to the side of the code.
Comment 4 Tomas Mraz 2009-04-10 12:09:48 EDT
I had to slightly modify the alternative stacks, there were some problems.
Built in rawhide. Ray, please test if you can.

Note You need to log in before you can comment on or make changes to this bug.