Bug 494893 - oracle init script do not support "status"
oracle init script do not support "status"
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Other (Show other bugs)
530
All Linux
low Severity low
: ---
: ---
Assigned To: Tomas Lestach
Jan Hutař
: Regression
Depends On:
Blocks: 456985 486216
  Show dependency treegraph
 
Reported: 2009-04-08 10:59 EDT by Jan Hutař
Modified: 2009-09-10 14:15 EDT (History)
1 user (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 14:15:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2009-04-08 10:59:36 EDT
Description of problem:
oracle init script do not support "status"


Version-Release number of selected component (if applicable):
Satellite-5.3.0-RHEL5-re20090401.0-x86_64


How reproducible:
always


Steps to Reproduce:
1. # rhn-satellite status   /   service oracle status


Actual results:
# rhn-satellite status
jabberd router (pid 26569) is running...
Usage: /etc/init.d/oracle start|stop|restart|reload
osa-dispatcher (pid 26863) is running...
/etc/init.d/tomcat5 is already running (27392)
httpd (pid 27623 27578 27445 27444 27443 27442 27441 27440 27439 27438 27417) is running...
rhn-search is not running.
cobblerd (pid 27502 27491 27490) is running...
RHN Taskomatic is not running.


Expected results:
should work
Comment 1 Brandon Perkins 2009-04-09 10:48:48 EDT
Accepting.

Old way:

# service rhn-database status
The database is running and accepting connections.

New way:

# service oracle status
Usage: /etc/init.d/oracle start|stop|restart|reload


I would expect service oracle status to return feedback consistent with Sat 5.2 and earlier.
Comment 2 Tomas Lestach 2009-04-21 04:08:12 EDT
Introduced "status" for the /etc/init.d/oracle script.

Commits in thirdparty.git [version 10.2.0.4-46]:
oracle-server.spec:   fd6f31c41e7b9aa8e39da59d4eaf7aa6df2af535
oracle-server-i386:   c837768c74a5656cbae24b76216b2aeb852a3219
oracle-server-x86_64: 317d10703fc10103e135a444be380c607e9abe90
oracle-server-s390x:  ddb20f7cd31abaac3155efd50798817a436693fe
Comment 3 Tomas Lestach 2009-04-27 09:05:36 EDT
Fix present in Satellite-5.3.0-RHEL5-re20090424.1-*, but not in Satellite-5.3.0-RHEL4-re20090424.1-*.
Filled rel-eng ticket #39798: Satellite: impossible to build RHEL4 oracle-server packages [version 10_2_0_4-46]
Comment 4 Tomas Lestach 2009-05-05 09:58:32 EDT
Fix present in RHEL4 composes since Satellite-5.3.0-RHEL4-re20090501.1
Comment 5 Jan Hutař 2009-05-21 04:10:56 EDT
Works on RHEL5 with 20090507.1
Comment 6 Michael Mráka 2009-08-03 09:36:31 EDT
Verified in stage -> RELEASE_PENDING.

# service oracle status
Oracle Net Listener (pid 8194) is running...
Oracle DB instance rhnsat (pid 8208) is running...
Comment 7 Brandon Perkins 2009-09-10 14:15:29 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.