Bug 494916 - Monitoring Errors Starting Service in Recent 530 Test ISOs
Monitoring Errors Starting Service in Recent 530 Test ISOs
Status: CLOSED DUPLICATE of bug 492150
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Monitoring (Show other bugs)
530
All Linux
high Severity medium
: ---
: ---
Assigned To: Miroslav Suchý
Preethi Thomas
:
Depends On:
Blocks: 463877
  Show dependency treegraph
 
Reported: 2009-04-08 13:32 EDT by Devan Goodwin
Modified: 2009-04-09 12:16 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-09 12:16:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Devan Goodwin 2009-04-08 13:32:30 EDT
Description of problem:

Monitoring appears somewhat broken in recent ISOs. Taking some wild guesses as to what the problem actually is but basically errors when starting services, and pushing scout configs just seems to always expire. More details below.

Version-Release number of selected component (if applicable):

ISO Satellite-5.3.0-RHEL5-re20090327.0-i386-embedded-oracle.iso

How reproducible:

Unclear, could be related to the environment where I'm testing in. (using some host file entries instead of actual DNS)

Steps to Reproduce:
1. Enable monitoring.
2. rhn-satellite restart
3.
  
Actual results:

Many error messages both on console and in logs, monitoring seemingly non-functional in the UI.


Additional info:

Starting with what I see on the console:

[root@satellite ~]# rhn-satellite restart
Shutting down rhn-satellite...
Stopping RHN Taskomatic...
Stopped RHN Taskomatic.
Stopping cobbler daemon:                                   [  OK  ]
Stopping rhn-search...
Stopped rhn-search.
Stopping MonitoringScout ...  Stopping Dispatcher ...  [ OK ]
Stopping Dequeuer ...  [ OK ]
Stopping SputLite ...  [ OK ]
Stopping NPBootstrap ...  [ OK ]
Stopping InstallSoftwareConfig ...  [ OK ]
[ OK ]
Stopping Monitoring ...  Stopping TSDBLocalQueue ...  [ OK ]
Stopping AckProcessor ...  [ OK ]
Stopping Notifier ...  [ OK ]
Stopping NotifLauncher ...  [ OK ]
Stopping NotifEscalator ...  [ OK ]
Stopping GenerateNotifConfig ...  [ OK ]
[ FAIL ]
[ OK ]
Stopping httpd:                                            [  OK  ]
Stopping tomcat5:                                          [  OK  ]
Shutting down osa-dispatcher:                              [  OK  ]
Shutdown Oracle: Processing Database instance "rhnsat": log file /opt/apps/oracle/web/product/10.2.0/db_1/log/shutdown.log
                                                           [  OK  ]
Shutting down Jabber router:                               [FAILED]
Done.
Starting rhn-satellite...
Starting Jabber services                                   [  OK  ]
Starting Oracle: Processing Database instance "rhnsat": log file /opt/apps/oracle/web/product/10.2.0/db_1/log/startup.log
                                                           [  OK  ]
Starting osa-dispatcher:                                   [  OK  ]
Starting tomcat5:                                          [  OK  ]
Starting httpd:                                            [  OK  ]
Starting Monitoring ...  Starting InstallSoftwareConfig ...  [ OK ]
Starting GenerateNotifConfig ...  [ OK ]
Starting NotifEscalator ...  [ OK ]
Starting NotifLauncher ...  [ OK ]
Starting Notifier ...  [ OK ]
Starting AckProcessor ...  [ OK ]
Starting TSDBLocalQueue ...  [ OK ]
[ OK ]
Starting MonitoringScout ...  [ FAIL ]
Starting NPBootstrap ...  2009-04-08 17:18:04 NPBootstrap: 	!! ERROR FROM SHELL COMMAND: 
2009-04-08 17:18:04 NPBootstrap: 	!! STDOUT: Requesting https://satellite.rm-rf.ca/satconfig/cgi-bin/fetch_netsaintid.cgi?ssk=5a73effefa2a&publickey=ssh-dss%20AAAAB3NzaC1kc3MAAACBAMbAZvJTNkdZOiUia1CIOY8h44GpOT2rQolpjMTheXcNPGcycL6glj%2BP4%2BclUs%2Bo7s5QwfjHxPnlEhIx3BzYCWuziw%2BysMVFyBGx2Ea8ekqSaQoXoYADglmPn0KhhndsXkCoZP3%2FMmKFvv8i1h3Y5DNbQ7ux0CrEqOVLnMOvPNhdAAAAFQCCdlR6AjXq1yAp81VSK57Ws6pEbwAAAIAyqMeAs5MPvYil2A5xa3VK1RmdVS94f%2FGbCYDXJMuZGP8BZEEFHqE3x7OuQa24pQlv8T5WOcUc3DgDKKWcFrEg%2FaFV0Szw87cMxiIgUq60poGvM7XUwGB71ila8RYulyKEOYy%2BPXm0i62MOWYotOou5z8PwLpzKehmSN%2FluicGsQAAAIAzl9XyQ12%2F1Rcpoa4g%2FFty5USuXB9APR%2FI5H2gAzggGPxK5RZZLwA%2BTc7cVj0UprkfwJZVuNebRGFq6VJTyaUaWS7lOgpDogFHb5tzLEOAw8xSOZk0ErkemNYrwv1ZwF8v%2FJeGWH2O0N0%2B%2FVWA4UFP7OZgp4JTTbn72KqqgqQnMg%3D%3D%20nocpulse%40satellite%2Erm-rf%2Eca%0A
Error on attempt 1:  Status: '500 Internal Server Error'; content: '

[followed by a printout of the error page HTML]

Failed 5 times to get data for this node.

2009-04-08 17:18:04 NPBootstrap: 	!! STDERR: 
2009-04-08 17:18:04 NPBootstrap: 	!! EXIT: 256
Starting SputLite ...  [ OK ]
Starting Dequeuer ...  [ OK ]
Starting Dispatcher ...  [ OK ]
[ OK ]
Starting rhn-search...
Starting cobbler daemon:                                   [  OK  ]
Starting RHN Taskomatic...
Done.




In httpd's error_log I see this:

==> ../httpd/error_log <==
[Wed Apr 08 17:18:04 2009] [error] returning 1 at /usr/lib/perl5/vendor_perl/5.8.8/RHN/Access.pm line 74.
[Wed Apr 08 17:18:06 2009] [error] [client 127.0.0.1] Can't locate object method "main" via package "Apache2::RequestRec" at /usr/lib/perl5/vendor_perl/5.8.8/NOCpulse/MonitoringAccessHandler.pm line 34.\n
[Wed Apr 08 17:18:07 2009] [error] returning 1 at /usr/lib/perl5/vendor_perl/5.8.8/RHN/Access.pm line 74.

/var/log/nocpulse looks mostly uninteresting except: 
==> kernel-error.log <==
2009-04-08 17:18:20  2009-04-08 17:18:20 Event terminated abnormally

==> kernel.log <==
2009-04-08 17:18:20 Event terminated abnormally
2009-04-08 17:18:20 Rescheduling at 300-second interval
2009-04-08 17:18:20 Reaped 0



As a side note hitting apparent mass breakage in spacewalk 0.5 on Fedora 10, though possibly for different reasons.

Will be doing a fresh Satellite ISO install in a better environment soon, will verify for sure this is happening there as well.
Comment 1 Miroslav Suchý 2009-04-09 12:16:38 EDT

*** This bug has been marked as a duplicate of bug 492150 ***

Note You need to log in before you can comment on or make changes to this bug.