Bug 494953 - NetworkManager-0.7.0.100-1.fc11 no longer connects to WPA-PSK network.
NetworkManager-0.7.0.100-1.fc11 no longer connects to WPA-PSK network.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-08 15:45 EDT by Alexander Dutton
Modified: 2010-04-23 17:39 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-23 17:39:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Dutton 2009-04-08 15:45:15 EDT
After upgrading to NetworkManager-0.7.0.100-1.fc11 with yum I could no longer connect to my wireless network which was secured using WPA-PSK. The tray applet shows only one of the green dots when attempting to connect.

There is a caveat to this though. Currently my machine isn't booting graphically, requiring logging in in text-mode and then running 'startx'. I noticed that NM now uses PolicyKit so it's possible there's something missing as a result of this broken booting.

I notice that before when NM asks for a PSK passphrase to be re-entered it would display the old input. It no longer does this.

In the meantime I have downgraded to NetworkManager-0.7.0.99-3.fc11 and can now connect again.
Comment 1 Dan Williams 2009-04-08 21:33:40 EDT
If you're not running a GUI, how is the connection configured, through ifcfg files in /etc/sysconfig/network-scripts?
Comment 2 Craig White 2009-04-09 10:35:37 EDT
I'm not even that far. I upgraded to F11-Beta (NM 0.7.100-1.fc11) from Fedora 10 and after login, wireless networking seems impossible.

The widget is in my status tray with an X and 'Enable Networking' is indeed checked.

I went to system-config-network, providing root authentication then all of the interfaces (eth0, pan0, wlan0) are inactive (eth0 will work when plugged in). If I click on any of them, I am not offered the opportunity to 'Activate' the Wireless at all.

not sure that it's significant but...

ifcfg-wlan0 (hand typed because networking is not happening)
# Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adaptor
DEVICE=wlan0
HWADDR=00:23...
BOOTPROTO=dhcp
TYPE=Wireless
ONBOOT=no
USERCTL=yes
PEERDNS=yes
IPV6INIT=no
NM_CONTROLLED=yes
ESSID=
CHANNEL=
MODE=Master
RATE=auto
Comment 3 Craig White 2009-04-09 19:37:39 EDT
nevermind...

modprobe -r acer_wmi

fixed it for me
Comment 4 Alexander Dutton 2009-04-16 07:39:23 EDT
Sorry about the delay. It turns out that as far as yum knew gdm wasn't installed due to a messed up switch from F10 to rawhide. Eventually the install that had been there broke. I've now reinstalled gdm (and various other things) and that doesn't seem to be relevant.

There seems to be very little rhyme or reason as to when it doesn't work. The chronology has been:

Working on Network A with old version
Upgrade to new version and no longer works with Network A
Downgrade to old and Network A works again
Try Network B and all is good
Upgrade again and it still works with Network B
Try Network A again and it doesn't work
Downgrade and it still doesn't work with Network A

iwlist provides the following about Network A:

wlan0     Scan completed :
          Cell 01 - Address: ##:##:##:##:##:##
                    ESSID:"BTVOYAGER2100-FF"
                    Protocol:IEEE 802.11g
                    Mode:Managed
                    Frequency:2.452 GHz (Channel 9)
                    Quality:51/100  Signal level:-63 dBm  Noise level:-96 dBm
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
                              12 Mb/s; 48 Mb/s
                    Extra:bcn_int=100
                    Extra:atim=0
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (1) : TKIP
                        Authentication Suites (1) : PSK
Comment 5 Bug Zapper 2009-06-09 09:30:50 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Dan Williams 2009-10-15 01:26:36 EDT
Is this still an issue with current F11 2.6.29-based kernels and latest NetworkManager-0.7.1-8.git20090708.fc11?  Also, what wifi hardware?  The output of 'lspci' should tell you for most cards.  Thanks!
Comment 7 Dan Williams 2009-11-10 20:17:48 EST
Give:

etworkManager-0.7.1.998-1.fc11 has been pushed to the Fedora
11 testing repository.  If problems still persist, please make note of it in
this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager'.  You can provide feedback for this update
here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-10696  

a shot, and also make sure you're running the lasted kernel updates (2.6.30.9-96.fc11).  Let me know what the result there is.

If that still fails, can you including your /var/log/messages from the time the problem happened?  Thanks!

Note You need to log in before you can comment on or make changes to this bug.