Bug 4950 - i/o error when smbmounted nt share 'times out'
i/o error when smbmounted nt share 'times out'
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: samba (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-09-07 05:29 EDT by redhat-bugzilla
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-20 11:41:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description redhat-bugzilla 1999-09-07 05:29:57 EDT
I think this is an old bug that has resurficed, i think
it was fixed in the smbmount 2.0.3 or something. When
i have shares from our nt server mounted on my linux and
don't touch them for a while they stop to work, and i get

[noa@purcell mp3]$ ls
ls: .: Input/output error

When i try to ls in the root of the mount. I can't umount
the share since it thinks that 'device is budy'

The samba-package that comes with redhat-6 doesnt have this
problem (it succeeds to remount when the connection dies)
Comment 1 Michael K. Johnson 1999-09-20 13:50:59 EDT
What version of samba do you have now?
Comment 2 dkaplan 1999-09-21 16:09:59 EDT
I am running RH 6.0 and am having similar problems with Samba.  I have
the problem that if i try to mount a share and make a typo, then
smbmount fails to unmount the directory on the way out and i get the
io error.  An example of the exchange is as follows:

$smbmount \\\\junk\\c /mnt/other
Added interface ip=192.168.1.1 bcast=192.168.1.255 nmask=255.255.255.0
Connection to junk failed
smbmount: login failed
Could not umount /mnt/other: Device or resource busy
smbmount: exit
$ls /mnt/other
ls: /mnt/other: Input/output error

This can be fixed with smbumount, but the problem is if I want to use
autofs then if for some reason the connection to a share breaks,
autofs cant remake the connection.
Comment 3 Bill Nottingham 1999-09-22 14:36:59 EDT
The reconnect problems should be fixed in samba-2.0.5a-11, which will
be in the next Raw Hide release.
Comment 4 John Hardin 1999-12-14 20:43:59 EST
smbmount timeouts of mounted filesystems still occur under samba-2.0.6-2.
smbumount cannot disconnect the dead mount, but root umount can. It appears this
bug should be reopened.
Comment 5 Bill Nottingham 1999-12-17 17:33:59 EST
Is this across reboots of the server?  Samba mounts
will *not* persist across this.
Comment 6 Bill Nottingham 2000-01-20 11:41:59 EST
closed, lack of input.
Comment 7 dkaplan 2000-01-20 12:17:59 EST
The problem I have with smbmount is that if for example I give a name that is
incorrect or the network is down, it tries to mount the share, realizes it cant
and then tries to undo what it did.  For some reason it cant and it leaves the
directory in some unusable state so that i have to smbumount the directory in
order to retry to mount it.  This is relevant if you use autofs since if the
connection is broken it cant later remount it.

This does not have to do with rebooting.

Note You need to log in before you can comment on or make changes to this bug.