Bug 495000 - r300 rendering broken on recent F11 kernels
r300 rendering broken on recent F11 kernels
Status: CLOSED DUPLICATE of bug 494737
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
powerpc Linux
low Severity high
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-08 21:54 EDT by Jeremy Huddleston
Modified: 2009-04-24 20:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-24 20:37:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
glxgears.png (8.09 KB, image/png)
2009-04-10 20:15 EDT, Jeremy Huddleston
no flags Details
Xorg.0.log (70.95 KB, text/plain)
2009-04-10 20:16 EDT, Jeremy Huddleston
no flags Details
dmesg.txt (28.85 KB, text/plain)
2009-04-10 20:17 EDT, Jeremy Huddleston
no flags Details

  None (edit)
Description Jeremy Huddleston 2009-04-08 21:54:16 EDT
Description of problem:

[jeremy@localhost ~]$ glxgears 
Failed to allocate :
   size      : 0 bytes
   alignment : 0 bytes
   domains   : 4
*********************************WARN_ONCE*********************************
File r300_render.c function r300Fallback line 431
Software fallback:r300->radeon.Fallback
***************************************************************************
Segmentation fault

Version-Release number of selected component (if applicable):


How reproducible:

works: 2.6.29.1-46.fc11.ppc
fails: 2.6.29.1-52.fc11
fails: 2.6.29.1-54.fc11

Steps to Reproduce:
1. boot into 2.6.29.1-46
2. run glxgears ... works
3. reboot into 2.6.29.1-52
4. run glxgears ... cry  

Actual results:

See above failure notice.  An X11 window appears briefly before the segfault.

Expected results:

Pretty gears spin and make you smile.

Additional info:

0000:00:10.0 VGA compatible controller: ATI Technologies Inc RV350 [Mobility Radeon 9600 M10] (prog-if 00 [VGA controller])
	Subsystem: ATI Technologies Inc RV350 [Mobility Radeon 9600 M10]
	Flags: bus master, 66MHz, medium devsel, latency 255, IRQ 48
	Memory at b8000000 (32-bit, prefetchable) [size=128M]
	I/O ports at 0400 [size=256]
	Memory at b0000000 (32-bit, non-prefetchable) [size=64K]
	Expansion ROM at f1000000 [size=128K]
	Capabilities: [58] AGP version 2.0
	Capabilities: [50] Power Management version 2
	Kernel driver in use: radeonfb
Comment 1 Jeremy Huddleston 2009-04-08 21:58:49 EDT
Adding Dave to CC since I suspect his change:
* Mon Apr 06 2009 Dave Airlie <airlied@redhat.com> -
radeon: bust APIs and move to what we want in the end.
Comment 2 Jeremy Huddleston 2009-04-10 20:15:33 EDT
Created attachment 339141 [details]
glxgears.png
Comment 3 Jeremy Huddleston 2009-04-10 20:16:38 EDT
Created attachment 339142 [details]
Xorg.0.log
Comment 4 Jeremy Huddleston 2009-04-10 20:17:33 EDT
Created attachment 339143 [details]
dmesg.txt
Comment 5 Jeremy Huddleston 2009-04-10 20:17:54 EDT
I have no xorg.conf
Comment 6 Jeremy Huddleston 2009-04-10 21:15:47 EDT
While this info might be helpful to you, it was intended for another bug.  Sorry for the spam.
Comment 7 Dave Airlie 2009-04-12 01:02:17 EDT
what version of mesa + -ati are installed?

you need to upgrade mesa/libdrm/-ati to latest rawhide for those kernels.
Comment 8 Jeremy Huddleston 2009-04-12 16:04:35 EDT
This is happening with the latest rawhide.  I have:

libdrm-2.4.6-4.fc11.ppc
mesa-*-7.5-0.6.fc11.ppc.rpm
xorg-x11-drv-ati-6.12.1-10.fc11.ppc

yes, rawhide has a newer version of mesa (-0.8), but that fails by #494737.
Comment 9 Jeremy Huddleston 2009-04-24 20:37:03 EDT
I'm marking this a dupe of #494737 ... since this particular issue doesn't occur when everything is updated (just #494737 occurs).  This issue only occurred when I run newer kernels with the older mesa that don't exhibit the bug in #494737.

*** This bug has been marked as a duplicate of bug 494737 ***

Note You need to log in before you can comment on or make changes to this bug.