Bug 495044 - Xcorruption with ATI Rage 128 on Dell Optiplex GX240
Xcorruption with ATI Rage 128 on Dell Optiplex GX240
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-r128 (Show other bugs)
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2009-04-09 06:56 EDT by Karl-Olov Serrander
Modified: 2018-04-11 03:21 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2010-06-28 07:45:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Xorg.0.log (32.95 KB, text/plain)
2009-04-09 06:58 EDT, Karl-Olov Serrander
no flags Details
related entries in /var/log/messages (8.84 KB, text/plain)
2009-04-09 07:01 EDT, Karl-Olov Serrander
no flags Details

  None (edit)
Description Karl-Olov Serrander 2009-04-09 06:56:02 EDT
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv: Gecko/2009032713 Fedora/3.0.8-1.fc10 Firefox/3.0.8

I get screen corruption (random pattern) when starting X, either via runlevel3 + startx or runlevel5. Console is hanged, Ctrl-Alt-FN does nothing. I have no xorg.conf. Updated to latest rawhide (kernel-, xorg-x11-drv-r128-6.8.0-3.fc11.i586)

Reproducible: Always

Steps to Reproduce:
1.Reboot to runleve1 3
2.Login as root
Actual Results:  
screen corrupted, console hanged.

Expected Results:  
Start gdm

lspci | grep VGA
01:00.0 VGA compatible controller: ATI Technologies Inc Rage 128 Pro Ultra TF
Comment 1 Karl-Olov Serrander 2009-04-09 06:58:32 EDT
Created attachment 338887 [details]

(EE) open /dev/fb0: No such file or directory
(EE) R128(0): No DFP detected
Comment 2 Karl-Olov Serrander 2009-04-09 07:01:32 EDT
Created attachment 338888 [details]
related entries in /var/log/messages
Comment 3 Karl-Olov Serrander 2009-05-08 06:48:21 EDT
kernel- seems to have solved the problem.
Comment 4 Bug Zapper 2009-06-09 09:32:16 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
Comment 5 Matěj Cepl 2009-11-05 13:25:52 EST
Since this bugzilla report was filed, there have been several major updates in various components of the Xorg system, which may have resolved this issue. Users who have experienced this problem are encouraged to upgrade their system to the latest version of their packages. For packages from updates-testing repository you can use command

yum upgrade --enablerepo='*-updates-testing'

Alternatively, you can also try to test whether this bug is reproducible with the upcoming Fedora 12 distribution by downloading LiveMedia of F12 Beta available at http://alt.fedoraproject.org/pub/alt/nightly-composes/ . By using that you get all the latest packages without need to install anything on your computer. For more information on using LiveMedia take a look at https://fedoraproject.org/wiki/FedoraLiveCD .

Please, if you experience this problem on the up-to-date system, let us now in the comment for this bug, or whether the upgraded system works for you.

If you won't be able to reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[This is a bulk message for all open Fedora Rawhide Xorg-related bugs. I'm adding myself to the CC list for each bug, so I'll see any comments you make after this and do my best to make sure every issue gets proper attention.]
Comment 6 Karl-Olov Serrander 2009-11-06 01:36:08 EST
Well, this machine has followed rawhide and now runs what will be Fedora 12 and the problem seems to have been solved in some of the updates.
Comment 7 Bug Zapper 2010-04-27 09:34:56 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 8 Bug Zapper 2010-06-28 07:45:46 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.