Bug 495063 - installation crash
installation crash
Status: CLOSED DUPLICATE of bug 493537
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:c400bec04348da979...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-09 10:24 EDT by Brian Clark
Modified: 2009-04-22 08:34 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-09 10:32:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (103.74 KB, text/plain)
2009-04-09 10:24 EDT, Brian Clark
no flags Details
Attached traceback automatically from anaconda. (146.92 KB, text/plain)
2009-04-17 18:02 EDT, Jason Brown
no flags Details
Attached traceback automatically from anaconda. (198.84 KB, text/plain)
2009-04-18 06:42 EDT, info@kobaltwit.be
no flags Details
Attached traceback automatically from anaconda. (175.42 KB, text/plain)
2009-04-22 08:34 EDT, Ben Lambrechts
no flags Details

  None (edit)
Description Brian Clark 2009-04-09 10:24:47 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.38 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/image.py", line 290, in unmountCD
    % (dev.path,))
  File "/usr/lib/anaconda/yuminstall.py", line 694, in mirrorFailureCB
    unmountCD(self.tree, self.anaconda.intf.messageWindow)
  File "/usr/lib/python2.6/site-packages/urlgrabber/mirror.py", line 301, in _failure
    action = cb(cb_obj, *args, **kwargs) or {}
  File "/usr/lib/python2.6/site-packages/urlgrabber/mirror.py", line 406, in _mirror_try
    self._failure(gr, obj)
  File "/usr/lib/python2.6/site-packages/urlgrabber/mirror.py", line 412, in urlgrab
    return self._mirror_try(func, url, kw)
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 781, in _getFile
    http_headers=headers,
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1474, in _retrieveMD
    cache=self.http_caching == 'all')
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 170, in populate
    db_fn = repo._retrieveMD(mydbtype)
  File "/usr/lib/python2.6/site-packages/yum/sqlitesack.py", line 553, in searchFiles
    self.populate(repo, mdtype='filelists')
  File "/usr/lib/python2.6/site-packages/yum/sqlitesack.py", line 44, in newFunc
    return func(*args, **kwargs)
  File "/usr/lib/python2.6/site-packages/yum/sqlitesack.py", line 852, in _search
    for pkg in self.searchFiles(name, strict=True):
  File "/usr/lib/python2.6/site-packages/yum/sqlitesack.py", line 44, in newFunc
    return func(*args, **kwargs)
  File "/usr/lib/python2.6/site-packages/yum/sqlitesack.py", line 876, in getProvides
    return self._search("provides", name, flags, version)
  File "/usr/lib/python2.6/site-packages/yum/packageSack.py", line 497, in _computeAggregateDictResult
    sackResult = apply(method, args)
  File "/usr/lib/python2.6/site-packages/yum/packageSack.py", line 327, in getProvides
    return self._computeAggregateDictResult("getProvides", name, flags, version)
  File "/usr/lib/python2.6/site-packages/yum/transactioninfo.py", line 424, in getNewProvides
    for pkg, hits in self.pkgSack.getProvides(name, flag, version).iteritems():
  File "/usr/lib/python2.6/site-packages/yum/transactioninfo.py", line 442, in getProvides
    result.update(self.getNewProvides(name, flag, version))
  File "/usr/lib/python2.6/site-packages/yum/depsolve.py", line 856, in _checkInstall
    provs = self.tsInfo.getProvides(*req)
  File "/usr/lib/python2.6/site-packages/yum/depsolve.py", line 784, in _resolveRequires
    thisneeds = self._checkInstall(txmbr)
  File "/usr/lib/python2.6/site-packages/yum/depsolve.py", line 699, in resolveDeps
    CheckDeps, checkinstalls, checkremoves, missing = self._resolveRequires(errors)
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 703, in buildTransaction
    (rescode, restring) = self.resolveDeps()
  File "/usr/lib/anaconda/yuminstall.py", line 1305, in doPostSelection
    (code, msgs) = self.ayum.buildTransaction()
  File "/usr/lib/anaconda/backend.py", line 278, in doPostSelection
    return anaconda.backend.doPostSelection(anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1317, in nextClicked
    self.anaconda.dispatch.gotoNext()
AttributeError: 'str' object has no attribute 'path'
Comment 1 Brian Clark 2009-04-09 10:24:53 EDT
Created attachment 338918 [details]
Attached traceback automatically from anaconda.
Comment 2 Chris Lumens 2009-04-09 10:32:39 EDT

*** This bug has been marked as a duplicate of bug 493537 ***
Comment 3 Jason Brown 2009-04-17 18:02:28 EDT
Created attachment 340101 [details]
Attached traceback automatically from anaconda.
Comment 4 info@kobaltwit.be 2009-04-18 06:42:17 EDT
Created attachment 340144 [details]
Attached traceback automatically from anaconda.
Comment 5 Ben Lambrechts 2009-04-22 08:34:01 EDT
Created attachment 340728 [details]
Attached traceback automatically from anaconda.

Note You need to log in before you can comment on or make changes to this bug.