Bug 495127 - screen is not correctly updated and error settexbuf 1280x1024@4 5120 targ 84f5 format 1401
screen is not correctly updated and error settexbuf 1280x1024@4 5120 targ 84f...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-09 16:26 EDT by Eddie Lania
Modified: 2018-04-11 05:22 EDT (History)
5 users (show)

See Also:
Fixed In Version: xorg-x11-drv-ati-6.12.2-14.fc11.i586
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-16 11:47:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
My xorg.log (68.95 KB, text/plain)
2009-04-10 12:07 EDT, Eddie Lania
no flags Details
And here is my dmesg too (30.71 KB, text/plain)
2009-04-10 12:11 EDT, Eddie Lania
no flags Details
Screenshot of problem. (434.73 KB, image/png)
2009-04-15 16:36 EDT, Eddie Lania
no flags Details

  None (edit)
Description Eddie Lania 2009-04-09 16:26:40 EDT
Description of problem:When compiz enabled on rawhide screen is not correctly updated and error settexbuf 1280x1024@4 5120 targ 84f5 format 1401 is in ~/.xsession-errors


Version-Release number of selected component (if applicable):
[root@f11-test ~]# rpm -qa |grep -i compiz
compizconfig-python-0.7.8-3.fc11.i586
compizconfig-backend-gconf-0.7.8-2.fc11.i586
compiz-0.7.8-18.fc11.i586
compiz-fusion-gnome-0.7.8-8.fc11.i586
compiz-gnome-0.7.8-18.fc11.i586
compiz-fusion-extras-gnome-0.7.8-6.fc11.i586
compiz-fusion-0.7.8-8.fc11.i586
libcompizconfig-0.7.8-3.fc11.i586
compiz-fusion-extras-0.7.8-6.fc11.i586

kernel-PAE-2.6.29.1-54.fc11.i686

xorg-x11-drv-ati-6.12.1-9.fc11.i586

mesa-libGLU-7.5-0.8.fc11.i586
mesa-libGL-7.5-0.8.fc11.i586
mesa-dri-drivers-7.5-0.8.fc11.i586

libdrm-2.4.6-3.fc11.i586


01:00.0 VGA compatible controller: ATI Technologies Inc RV350 AR [Radeon 9600] (prog-if 00 [VGA controller])
01:00.1 Display controller: ATI Technologies Inc RV350 AR [Radeon 9600] (Secondary)


How reproducible:
Install compiz on rawhide.


Steps to Reproduce:
1.
2.
3.
  
Actual results: For instance: When open terminal and typing in it, nothing is show on screen or is corrupted until terminal window is moved. But other windows like browsing files or folders in nautilus show this behaviour too.

And errors like below are constantly being logged in ~/.xsession-errors

ettexbuf 1280x1024@4 5120 targ 84f5 format 1401
settexbuf 1280x33@4 5120 targ 84f5 format 1401
settexbuf 1280x25@4 5120 targ 84f5 format 1401
settexbuf 1280x1024@4 5120 targ 84f5 format 1401
settexbuf 1280x33@4 5120 targ 84f5 format 1401
settexbuf 37x37@4 192 targ 84f5 format 1401
settexbuf 1280x25@4 5120 targ 84f5 format 1401
settexbuf 37x37@4 192 targ 84f5 format 1401
settexbuf 1280x33@4 5120 targ 84f5 format 1401
settexbuf 1280x33@4 5120 targ 84f5 format 1401
settexbuf 1280x33@4 5120 targ 84f5 format 1401
settexbuf 1280x33@4 5120 targ 84f5 format 1401
settexbuf 1280x33@4 5120 targ 84f5 format 1401
settexbuf 1280x33@4 5120 targ 84f5 format 1401
settexbuf 1280x33@4 5120 targ 84f5 format 1401
settexbuf 1280x33@4 5120 targ 84f5 format 1401
settexbuf 1280x1024@4 5120 targ 84f5 format 1401
settexbuf 1280x25@4 5120 targ 84f5 format 1401
settexbuf 1280x33@4 5120 targ 84f5 format 1401
settexbuf 37x37@4 192 targ 84f5 format 1401
settexbuf 1280x1024@4 5120 targ 84f5 format 1401
settexbuf 1280x25@4 5120 targ 84f5 format 1401
settexbuf 1280x33@4 5120 targ 84f5 format 1401
settexbuf 37x37@4 192 targ 84f5 format 1401
settexbuf 170x170@4 704 targ 84f5 format 1401
settexbuf 1280x1024@4 5120 targ 84f5 format 1401
settexbuf 1280x33@4 5120 targ 84f5 format 1401
settexbuf 37x37@4 192 targ 84f5 format 1401
settexbuf 170x170@4 704 targ 84f5 format 1401




Expected results:
No errors and windows being correctly refreshed.

Additional info:
Comment 1 Matěj Cepl 2009-04-10 11:16:34 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Eddie Lania 2009-04-10 12:07:57 EDT
Created attachment 339105 [details]
My xorg.log

My Xorg.0.log per as requested.
Comment 3 Eddie Lania 2009-04-10 12:09:45 EDT
PS: I am not using an xorg.conf
Comment 4 Eddie Lania 2009-04-10 12:11:21 EDT
Created attachment 339107 [details]
And here is my dmesg too

And here is my dmesg too.
Comment 5 Eddie Lania 2009-04-11 14:47:32 EDT
Can somebody yet confirm this bug? It makes using compiz desktop effects pretty unusable.
Comment 6 Eddie Lania 2009-04-15 12:39:31 EDT
I am still getting these errors and screen is still garbled.

Please, can somebody help?


mesa-dri-drivers-7.5-0.9.fc11.i586
mesa-libGLU-7.5-0.9.fc11.i586
mesa-libGL-7.5-0.9.fc11.i586

xorg-x11-drv-ati-6.12.1-10.fc11.i586

libdrm-2.4.6-4.fc11.i586
Comment 7 Eddie Lania 2009-04-15 12:41:02 EDT
PS: In order to see this problem, compiz must be running.
Comment 8 Eddie Lania 2009-04-15 16:36:11 EDT
Created attachment 339742 [details]
Screenshot of problem.
Comment 9 Eddie Lania 2009-04-15 16:54:55 EDT
The screen-shot was taken using the latest rpms:

mesa-dri-drivers-7.5-0.9.fc11.i586
mesa-libGLU-7.5-0.9.fc11.i586
mesa-libGL-7.5-0.9.fc11.i586

xorg-x11-drv-ati-6.12.2-2.fc11.i586

libdrm-2.4.6-4.fc11.i586

compiz-0.7.8-18.fc11.i586
compiz-fusion-extras-gnome-0.7.8-6.fc11.i586
compiz-fusion-gnome-0.7.8-8.fc11.i586
compiz-fusion-0.7.8-8.fc11.i586
compiz-fusion-extras-0.7.8-6.fc11.i586
compizconfig-backend-gconf-0.7.8-2.fc11.i586
libcompizconfig-0.7.8-3.fc11.i586
compiz-gnome-0.7.8-18.fc11.i586
compizconfig-python-0.7.8-3.fc11.i586
Comment 10 Eddie Lania 2009-04-22 02:51:23 EDT
I have some more information regarding this issue.

When I don't use the "fusion-icon" program to enable compiz but instead use the "desktop-effects" application, the problem does NOT appear.

When using "desktop-effects" to enable compiz, the garbeled screens are gone and also I do not get the settexbuf errors in the ~/.xsession-errors log.

I do not know what the difference is between enabling compiz through "fusion-icon" and "desktop-effects" but it clearly makes a big difference.

I really hope this information is useful.

Regards,

Eddie.
Comment 11 Björn Ruberg 2009-04-26 18:05:22 EDT
I can confirm this bug on GM965. Don't see those errors when starting compiz via desktop-effects , but when I use compiz-manager.
Maybe it is triggered by a special compiz-plugin? Will try to investigate.

kwin is not affected either. Just compiz.
Comment 12 Adel Gadllah 2009-04-28 08:05:43 EDT
fusion-icon does start compiz using compizmanager which contains a bunch of hacks that seem cause problems with recent drivers (have not looked at them in detail because its not the default way we start compiz for a reason).

desktop-effects starts compiz without any such heuristics or hacks and therefore works.
Comment 13 Björn Ruberg 2009-04-29 11:13:06 EDT
Well, turning on "indirect rendering" in the fusion icon does help.
Comment 14 Adel Gadllah 2009-04-30 15:49:50 EDT
(In reply to comment #13)
> Well, turning on "indirect rendering" in the fusion icon does help.  

OK, did not know that fusion-icon tries to use direct rendering by default.

Even thought DRI2 should allow you to use compiz in direct rendering mode it seems that it is not there yet.
Comment 15 Eddie Lania 2009-05-01 02:35:12 EDT
I cannot start compiz anymore. No matter is I try "desktop-effects" or "fusion-icon", X immediately segfaults and I am being dropped back to the login screen.

Apr 29 20:20:22 p3000fedora kernel: Xorg[2153]: segfault at 0 ip 0812e646 sp bffbc198 error 4 in Xorg (deleted)[8047000+1ba000]
Apr 29 20:21:18 p3000fedora kernel: Xorg[23259]: segfault at 0 ip 0812e646 sp bfab4c98 error 4 in Xorg[8047000+1ba000]
Apr 29 20:28:43 p3000fedora kernel: Xorg[24694]: segfault at 0 ip 0812e646 sp bfc86678 error 4 in Xorg[8047000+1ba000]
Apr 29 20:29:14 p3000fedora kernel: Xorg[25340]: segfault at 0 ip 0812e646 sp bfab0c98 error 4 in Xorg[8047000+1ba000]
Apr 29 20:57:12 p3000fedora kernel: Xorg[2035]: segfault at 0 ip 0812e646 sp bfe2f008 error 4 in Xorg[8047000+1ba000]
Apr 30 10:20:04 p3000fedora kernel: Xorg[2030]: segfault at 0 ip 0812e646 sp bfc4ce68 error 4 in Xorg[8047000+1ba000]
Apr 30 10:46:35 p3000fedora kernel: sealert[3673]: segfault at 3a2df6d2 ip 0732eca2 sp bff59490 error 4 in libpython2.6.so.1.0[72ae000+14f000]
Apr 30 22:31:26 p3000fedora kernel: Xorg[2048]: segfault at 0 ip 0812e646 sp bff88968 error 4 in Xorg[8047000+1ba000]
Apr 30 22:32:00 p3000fedora kernel: Xorg[3655]: segfault at 0 ip 0812e646 sp bfa4f438 error 4 in Xorg[8047000+1ba000]
Apr 30 22:32:31 p3000fedora kernel: Xorg[4296]: segfault at 0 ip 0812e646 sp bf86ca58 error 4 in Xorg[8047000+1ba000]
Comment 16 Eddie Lania 2009-05-02 08:49:02 EDT
I've been able to run compiz-fusion after persistently retrying to start it, and confirm that enabling "Indirect rendering" in the fusion-icon indeed solves the problem.
Comment 17 Eddie Lania 2009-05-04 14:00:53 EDT
Question: according to the policy, current development for f11 has been frozen.
Does this mean this will not be solved before the final f11 release?
Comment 18 Eddie Lania 2009-05-13 13:28:48 EDT
Just installed the latest packages for Mesa. It seems to be solved now. Compiz starts and runs fine and, no garbled windows anymore. And also the setex errors are gone.

I will keep testing tough.

Regards,

Eddie.
Comment 19 Eddie Lania 2009-05-16 09:54:23 EDT
All is still working well.

Currently using the following driver:

xorg-x11-drv-ati-6.12.2-14.fc11.i586

mesa-libGLw-6.5.1-7.fc11.i586
mesa-libOSMesa-7.5-0.14.fc11.i586
mesa-dri-drivers-7.5-0.14.fc11.i586
mesa-libGLU-devel-7.5-0.14.fc11.i586
mesa-libGL-devel-7.5-0.14.fc11.i586
mesa-libGL-7.5-0.14.fc11.i586
mesa-libOSMesa-devel-7.5-0.14.fc11.i586
mesa-libGLU-7.5-0.14.fc11.i586

I unchecked "indirect rendering" in "fusion icon" and it seems to be solved now. Compiz starts and runs fine and, no garbled windows anymore. And also the setex errors are gone.

I think the latest mesa update solved it for me.

Thank you.
Comment 20 Matěj Cepl 2009-05-16 11:47:27 EDT
Thanks for letting us know.

Note You need to log in before you can comment on or make changes to this bug.