Bug 495136 - Add support for setting paper sizes in Publican-created PDFs
Add support for setting paper sizes in Publican-created PDFs
Status: CLOSED ERRATA
Product: Publican
Classification: Community
Component: publican (Show other bugs)
1.6
All Linux
low Severity low
: ---
: ---
Assigned To: Ruediger Landmann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-09 17:18 EDT by Jared Smith
Modified: 2010-11-23 23:16 EST (History)
4 users (show)

See Also:
Fixed In Version: 1.2-0.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-20 00:20:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to make it much easier to specify paper sizes in Publican (4.97 KB, patch)
2009-04-09 17:18 EDT, Jared Smith
no flags Details | Diff
Patch to set both paper size and body font size for Publican (6.36 KB, patch)
2009-06-22 16:12 EDT, Jared Smith
no flags Details | Diff
Patch to make it much easier to specify paper sizes in new Publican Beta (1.40 KB, patch)
2009-08-04 23:16 EDT, Jared Smith
no flags Details | Diff

  None (edit)
Description Jared Smith 2009-04-09 17:18:33 EDT
Created attachment 338999 [details]
Patch to make it much easier to specify paper sizes in Publican

Description of problem:

I've always wanted to be able to set the paper size on a document-by-document basis in Publican, so I finally wrote a patch.

Version-Release number of selected component (if applicable):

My patch is against SVN trunk

I'll attach the patch as an attachment to this bug. I've only adjusted the Makefile template for the common template... obviously this would extend just as well to the fedora, o-virt, jboss templates as well.
Comment 1 Jared Smith 2009-04-27 11:38:22 EDT
Could I please get some feedback on this feature?  I'm not trying to be pushy -- just curious on getting some feedback.  I realize that there have been some changes with regards to Publican (but don't really understand what happened there), and I wanted to make sure this didn't fall through the cracks.

Is this a useful feature?  If nobody else finds it useful, I'll just keep my patches for my own use.

Was it implemented correctly?  If not, I'm happy to receive feedback to make it fit better within the Publican framework.
Comment 2 John J. McDonough 2009-06-08 07:34:01 EDT
I've been editing my stylesheet which is a totally unsatisfactory solution.
Comment 3 Bug Zapper 2009-06-09 09:34:28 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Michael Hideo 2009-06-16 22:28:50 EDT
Saving for the print-ready QA run. Need to test with Asian and Indic languages.
Comment 5 Jared Smith 2009-06-22 15:24:00 EDT
I'm not sure why Asian and Indic languages would make a difference with regards to paper sizes... but that's probably just my lack of understanding.

If there is anything else I can do to help push this forward, don't hesitate to let me know.
Comment 6 Jared Smith 2009-06-22 16:12:56 EDT
Created attachment 348991 [details]
Patch to set both paper size and body font size for Publican

Kushal Das and I were chatting on the #fedora-docs IRC channel today, and he found this patch useful, but said that in his case, he wanted to change the body font size as well, as the default font size was too large for A5-sized paper.

I realize that the two settings (paper size and font size) aren't directly related, but since they were some similar in the way that they could be handled by Publican, I decided to post another patch.

Feel free to ignore this second patch if you don't think font size should be set the same way.  (This new patch has not been tested, either.)

Patch is against SVN trunk.
Comment 7 Jared Smith 2009-08-04 23:16:50 EDT
Created attachment 356264 [details]
Patch to make it much easier to specify paper sizes in new Publican Beta

I've updated my paper-size patch for the new Publican beta, and I'd really like some feedback on whether or not you think it is appropriate to be added to Publican.  

(I have several other XSL stylesheet parameters I'd like to expose via the publican.cfg configuration file, but I'll start out with this simple one for now.)
Comment 8 Jeff Fearn 2009-10-01 19:58:06 EDT
The beta will accept xsl of the form '^pdf*' to allow custom pdf sizes, this xsl file could be shipped with a brand package.

e.g.

/usr/share/...../xsl/pdfA3.xsl

publican build --formats=pdfA3 --langs en-US


See: https://www.redhat.com/archives/publican-list/2009-May/msg00000.html
Comment 9 Fedora Update System 2009-11-17 21:18:44 EST
publican-1.2-0.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/publican-1.2-0.fc12
Comment 10 Fedora Update System 2009-11-20 00:17:48 EST
publican-1.2-0.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2009-11-25 09:52:55 EST
publican-1.2-0.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.