This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 495137 - Bad file descriptor errror from taskomatic + cobbler
Bad file descriptor errror from taskomatic + cobbler
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Mike McCune
Steve Salevan
: Reopened
Depends On:
Blocks: 457075
  Show dependency treegraph
 
Reported: 2009-04-09 17:23 EDT by Mike McCune
Modified: 2009-09-10 15:25 EDT (History)
1 user (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 15:25:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike McCune 2009-04-09 17:23:33 EDT
After a certain period of time running taskomatic starts to fail to connect to cobbler with the following error:

INFO   | jvm 1    | 2009/04/09 15:17:00 | java.lang.RuntimeException: java.lang.reflect.InvocationTargetException
INFO   | jvm 1    | 2009/04/09 15:17:00 | 	at com.redhat.rhn.common.util.MethodUtil.callNewMethod(MethodUtil.java:276)
INFO   | jvm 1    | 2009/04/09 15:17:00 | 	at com.redhat.rhn.common.util.MethodUtil.getClassFromConfig(MethodUtil.java:235)
INFO   | jvm 1    | 2009/04/09 15:17:00 | 	at com.redhat.rhn.manager.kickstart.cobbler.CobblerXMLRPCHelper.getCobblerUrl(CobblerXMLRPCHelper.java:100)
INFO   | jvm 1    | 2009/04/09 15:17:00 | 	at com.redhat.rhn.manager.kickstart.cobbler.CobblerXMLRPCHelper.<init>(CobblerXMLRPCHelper.java:51)
INFO   | jvm 1    | 2009/04/09 15:17:00 | 	at sun.reflect.GeneratedConstructorAccessor24.newInstance(Unknown Source)
INFO   | jvm 1    | 2009/04/09 15:17:00 | 	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
INFO   | jvm 1    | 2009/04/09 15:17:00 | 	at java.lang.reflect.Constructor.newInstance(Constructor.java:532)
INFO   | jvm 1    | 2009/04/09 15:17:00 | 	at java.lang.Class.newInstance0(Class.java:372)
INFO   | jvm 1    | 2009/04/09 15:17:00 | 	at java.lang.Class.newInstance(Class.java:325)
INFO   | jvm 1    | 2009/04/09 15:17:00 | 	at com.redhat.rhn.common.util.MethodUtil.callNewMethod(MethodUtil.java:261)
INFO   | jvm 1    | 2009/04/09 15:17:00 | 	at com.redhat.rhn.common.util.MethodUtil.getClassFromConfig(MethodUtil.java:235)
INFO   | jvm 1    | 2009/04/09 15:17:00 | 	at com.redhat.rhn.taskomatic.task.CobblerSyncTask.execute(CobblerSyncTask.java:71)
INFO   | jvm 1    | 2009/04/09 15:17:00 | 	at com.redhat.rhn.taskomatic.task.SingleThreadedTestableTask.execute(SingleThreadedTestableTask.java:54)
INFO   | jvm 1    | 2009/04/09 15:17:00 | 	at org.quartz.core.JobRunShell.run(JobRunShell.java:203)
INFO   | jvm 1    | 2009/04/09 15:17:00 | 	at org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThreadPool.java:520)
INFO   | jvm 1    | 2009/04/09 15:17:00 | Caused by: java.lang.reflect.InvocationTargetException
INFO   | jvm 1    | 2009/04/09 15:17:00 | 	at sun.reflect.GeneratedConstructorAccessor32.newInstance(Unknown Source)
INFO   | jvm 1    | 2009/04/09 15:17:00 | 	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
INFO   | jvm 1    | 2009/04/09 15:17:00 | 	at java.lang.reflect.Constructor.newInstance(Constructor.java:532)
INFO   | jvm 1    | 2009/04/09 15:17:00 | 	at com.redhat.rhn.common.util.MethodUtil.callNewMethod(MethodUtil.java:268)
INFO   | jvm 1    | 2009/04/09 15:17:00 | 	... 14 more
INFO   | jvm 1    | 2009/04/09 15:17:00 | Caused by: org.cobbler.XmlRpcException: redstone.xmlrpc.XmlRpcFault: exceptions.IOError:[Errno 9] Bad file descriptor
INFO   | jvm 1    | 2009/04/09 15:17:00 | 	at org.cobbler.CobblerConnection.adjustUrl(CobblerConnection.java:210)
INFO   | jvm 1    | 2009/04/09 15:17:00 | 	at org.cobbler.CobblerConnection.<init>(CobblerConnection.java:58)
INFO   | jvm 1    | 2009/04/09 15:17:00 | 	... 18 more
INFO   | jvm 1    | 2009/04/09 15:17:00 | Caused by: redstone.xmlrpc.XmlRpcFault: exceptions.IOError:[Errno 9] Bad file descriptor
INFO   | jvm 1    | 2009/04/09 15:17:00 | 	at redstone.xmlrpc.XmlRpcClient.handleResponse(XmlRpcClient.java:443)
INFO   | jvm 1    | 2009/04/09 15:17:00 | 	at redstone.xmlrpc.XmlRpcClient.endCall(XmlRpcClient.java:376)
INFO   | jvm 1    | 2009/04/09 15:17:00 | 	at redstone.xmlrpc.XmlRpcClient.invoke(XmlRpcClient.java:165)
INFO   | jvm 1    | 2009/04/09 15:17:00 | 	at org.cobbler.CobblerConnection.adjustUrl(CobblerConnection.java:197)
INFO   | jvm 1    | 2009/04/09 15:17:00 | 	... 19 more
Comment 1 Mike McCune 2009-04-09 17:24:09 EDT
possible theory is that the xmlrpc client needs to get recycled with each run instead of leaving it open.
Comment 2 Mike McCune 2009-04-09 19:39:46 EDT
latest version of java code no longer calls cobbler's api version check.  this should go away in next build.
Comment 3 Mike McCune 2009-04-22 18:30:35 EDT
ON_QA
Comment 4 Mike McCune 2009-05-20 13:29:04 EDT
ON_QA
Comment 5 Steve Salevan 2009-05-28 15:39:23 EDT
VERIFIED on 5/21 build.
Comment 6 Milan Zazrivec 2009-08-12 04:57:47 EDT
Verified in stage -> RELEASE_PENDING
Comment 7 Brandon Perkins 2009-09-10 15:25:04 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.