Bug 495142 - mkinitrd hangs on jbd
mkinitrd hangs on jbd
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: mkinitrd (Show other bugs)
5.3
x86_64 Linux
low Severity urgent
: rc
: ---
Assigned To: Brian Lane
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-09 17:58 EDT by Don Vanco
Modified: 2013-03-20 09:50 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-20 09:50:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Don Vanco 2009-04-09 17:58:17 EDT
Description of problem:
When trying to build a new initrd to include scsi hardware handlers for IBM storage, the mkinitrd process hangs at jbd

Version-Release number of selected component (if applicable):
The kernel is 2.6.18-128.el5 as found in a freshly installed RHEL5U3 64-bit host

How reproducible:
I had an installed server that had no multipathing configured.  I was able to run the mkinitrd process ONCE without issue.  I rebooted to the new initrd image and functional multipathing, and on that host I could no longer run the mkinitrd command.

On a second host I installed with multipath enabled (booted with "Boot: linux mpath") and this host will not run the mkinitrd command at all.

Steps to Reproduce:
1. run the following:
[root@orastgdb01 ~]# mkinitrd -v --preload=scsi_dh_rdac --with=dm-rdac
-f /boot/initrd-$(uname -r)-multipath.img $(uname -r)
Creating initramfs
Looking for deps of module scsi_dh_rdac: scsi_mod scsi_dh
Looking for deps of module scsi_mod
Looking for deps of module sd_mod: scsi_mod
Looking for deps of module scsi_dh: scsi_mod
Looking for deps of module ehci-hcd
Looking for deps of module ohci-hcd
Looking for deps of module uhci-hcd
Looking for deps of module ext3: jbd
Looking for deps of module jbd
........
2.
3.
  
Actual results:
It hangs

Expected results:
An initrdimage

Additional info:
Hosts are IBM HS21 Blades
SAN is an IBM DS4800

It would appear (based on Google results) that this was a bug in Fedora marked as "Not to be fixed".  This is a major issue - I can't build an initrd to get multipath up on these hosts!  I need a solution.
Comment 1 Christopher Jones 2010-10-25 11:57:28 EDT
I am also experiencing this exact problem with RHEL 5.5 running kernel version 2.6.18-194.17.1.el5:

[root@bbl boot]# mkinitrd -v -f /boot/initrd-2.6.18-194.17.1.el5.img 2.6.18-194.17.1.el5
Creating initramfs
Looking for deps of module ehci-hcd
Looking for deps of module ohci-hcd
Looking for deps of module uhci-hcd
Looking for deps of module ext3: jbd 
Looking for deps of module jbd

... hangs here ...

In order to address an issue with the shipped LSI MPT Fusion driver, I need to install the latest version (mptlinux-4.00.43.00-1.x86_64), but the installation fails due to the mkinitrd problem above.

Please increase the priority of this issue.  This issue was found in Fedora 12, RHEL 5.3, and I now see it as well in RHEL 5.5.
Comment 2 Nelson Coelho 2010-11-04 06:25:12 EDT
RHEL5.3 host SAS attached to a MSA2312sa firmware M111R06 with HP Enablement kit v4.4.1 kit installed

http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=us&prodTypeId=12169&prodSeriesId=3559651&swItem=co-82195-1&prodNameId=3559652&swEnvOID=4004&swLang=13&taskId=135&mode=4&idx=0#mptsad_parameters


While trying to “Configuring mptsas parameters “ as per the HP DM Enablement kit v4.4.1 release notes” we get problems:
 
To configure the mptsas parameters for RHEL 5, complete the following steps:
 
1.     Edit the /etc/modprobe.conf file in RHEL 5 hosts with the following values:
 
options mptsas mpt_cmd_retry_count=10 mpt_disable_hotplug_remove=1
 
2.     Rebuild the initrd by executing the following commands:
 
a.     Backup the existing initrd image by executing the following command:
 
# mv /boot/HP-initrd-2.6.18-128.el5.img-0 /boot/HP-initrd-2.6.18-128.el5.img-0.old
 
b.    Make a new initrd image by executing the following command:
 
# mkinitrd /boot/HP-initrd-2.6.18-128.el5.img-0 'uname -r'
/sbin/mkinitrd: line 1028: [: /lib/modules/uname: binary operator expected
No module ehci-hcd found for kernel uname -r, aborting.

It seems there is some fundamental error in mkinitrd script creating initrd.

        <snip>
           # mkinitrd -v /boot/HP-initrd-2.6.18-128.el5.img-0 'uname -r'
                /sbin/mkinitrd: line 1028: [: /lib/modules/uname: binary operator expected
                Creating initramfs
                Looking for deps of module ehci-hcd
                No module ehci-hcd found for kernel uname -r, aborting.
            
          # mkinitrd -v /boot/HP-initrd-2.6.18-128.el5.img-0 'uname -r'
                /sbin/mkinitrd: line 1028: [: /lib/modules/uname: binary operator expected
                Creating initramfs
                Looking for deps of module ehci-hcd
                No module ehci-hcd found for kernel uname -r, aborting.
           # lsmod |grep ehci-hcd
           # modprobe ehci-hcd
           # lsmod |grep ehci-hcd
           # mkinitrd -v HP-initrd-2.6.18-128.el5.img-0 'uname -r'
            /sbin/mkinitrd: line 1028: [: /lib/modules/uname: binary operator expected
            Creating initramfs
            Looking for deps of module ehci-hcd
            No module ehci-hcd found for kernel uname -r, aborting.
        </snip>

So with the following workaround it worked, but does not look like it is correct, because creating of initrd file was quite suspicious:
<snip>
# mkinitrd -v --allow-missing  /boot/HP-initrd-2.6.18-128.el5.img-0 'uname -r'
/sbin/mkinitrd: line 1028: [: /lib/modules/uname: binary operator expected
Creating initramfs
Looking for deps of module ehci-hcd
WARNING: No module ehci-hcd found for kernel uname -r, continuing anyway
Looking for deps of module ohci-hcd
WARNING: No module ohci-hcd found for kernel uname -r, continuing anyway
Looking for deps of module uhci-hcd
WARNING: No module uhci-hcd found for kernel uname -r, continuing anyway
Looking for deps of module ext3
Found root device cciss!c0d0p1 for LABEL=/1
Looking for driver for device cciss!c0d0p1
Looking for deps of module pci:v0000103Cd0000323Asv0000103Csd00003245bc01sc04i00
Looking for deps of module cciss
WARNING: No module cciss found for kernel uname -r, continuing anyway
Looking for deps of module pci:v00008086d00003408sv00000000sd00000000bc06sc04i00
Looking for driver for device cciss/c0d0p2
Looking for deps of module mptbase
WARNING: No module mptbase found for kernel uname -r, continuing anyway
Looking for deps of module mptsas
WARNING: No module mptsas found for kernel uname -r, continuing anyway
Looking for deps of module cciss
WARNING: No module cciss found for kernel uname -r, continuing anyway
Looking for deps of module ata_piix
WARNING: No module ata_piix found for kernel uname -r, continuing anyway
Looking for deps of module qla2xxx
WARNING: No module qla2xxx found for kernel uname -r, continuing anyway
Looking for deps of module mptscsih
WARNING: No module mptscsih found for kernel uname -r, continuing anyway
Looking for deps of module mptspi
WARNING: No module mptspi found for kernel uname -r, continuing anyway
Looking for deps of module ide-disk
Looking for deps of module dm-mod
Looking for deps of module dm-mirror
Looking for deps of module dm-zero
Looking for deps of module dm-snapshot
Using modules: 
/sbin/nash -> /tmp/initrd.L23587/bin/nash
/sbin/insmod.static -> /tmp/initrd.L23587/bin/insmod
</snip>

And also,  size of created initrd file is half than the "older" one.

When is this going to be fixed?
Comment 3 David Cantrell 2013-03-20 09:50:48 EDT
At this point in the RHEL-5 lifecycle, it is too late for us to commit to a change like this.

Note You need to log in before you can comment on or make changes to this bug.