Bug 495187 - Use all available cores when building the rpm
Use all available cores when building the rpm
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xulrunner (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-10 03:07 EDT by Yanko Kaneti
Modified: 2009-04-11 05:31 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-10 19:44:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yanko Kaneti 2009-04-10 03:07:29 EDT
xulrunner.spec

-[ "$RPM_BUILD_NCPUS" -gt 1 ] && MOZ_SMP_FLAGS=-j2
+[ "$RPM_BUILD_NCPUS" -gt 1 ] && MOZ_SMP_FLAGS=-j$RPM_BUILD_NCPUS


Here it builds fine with 4. And twice as fast...
Comment 1 Christopher Aillon 2009-04-10 19:44:02 EDT
The problem isn't your machine.  Mine also works fine.  The problem is that it sometimes fails in koji.  Often enough for us to do this.
Comment 2 Yanko Kaneti 2009-04-11 05:31:22 EDT
These things are upstream bugs, that might have been fixed in the year+ that has passed since you made the change.

Note You need to log in before you can comment on or make changes to this bug.