Bug 495192 - RHEL5: login command does not allow for switching users
RHEL5: login command does not allow for switching users
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: util-linux (Show other bugs)
5.0
All Linux
low Severity low
: rc
: ---
Assigned To: Karel Zak
Martin Cermak
:
Depends On: 489031
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-10 04:22 EDT by Karel Zak
Modified: 2011-01-13 18:44 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 489031
Environment:
Last Closed: 2011-01-13 18:44:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Zak 2009-04-10 04:22:28 EDT
+++ This bug was initially created as a clone of Bug #489031 +++

Description of problem: The manpage for the login command states:

"login is used when signing onto a system.  It can also be used to switch from one user to another at any time (most modern shells have support for this feature built into them, however)."

However it appears that switching-users with login does not work properly.  The issue seems to vary from not accepting keyboard input when run in an ssh session, to immediately returning to the prompt when run as a regular user, to failing with 'Login Incorrect' when trying to log in as root.  It only seems to work sometimes when logged in locally, running as root, and logging in as a regular user.   

Since the shells have built in support for switching users with su can we maybe remove the note in the manpage about being able to switch users?  Some customers of ours have been disappointed when the functionality did not match what was documented.

Version-Release number of selected component (if applicable): util-linux-2.12a-20.el4

--- Additional comment from kzak@redhat.com on 2009-03-09 04:48:57 EDT ---

You're right. The comment in the man page is nonsense. login(1) is not usable for users switching at all (see BUGS section in the same man page).

Thanks. Fixed in upstream code.
Comment 5 Martin Cermak 2010-11-29 10:07:11 EST
Comment #4 => VERIFIED
Comment 7 errata-xmlrpc 2011-01-13 18:44:56 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0085.html

Note You need to log in before you can comment on or make changes to this bug.