Bug 495221 - CS 8.0 Alpha -- ESC unable to successfully use https communications
CS 8.0 Alpha -- ESC unable to successfully use https communications
Status: CLOSED NOTABUG
Product: Dogtag Certificate System
Classification: Community
Component: ESC (Show other bugs)
1.0
All Linux
high Severity high
: ---
: ---
Assigned To: Jack Magne
Chandrasekar Kannan
:
Depends On:
Blocks: 443788
  Show dependency treegraph
 
Reported: 2009-04-10 10:28 EDT by Sean Veale
Modified: 2015-01-04 18:37 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-07 10:48:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Includes error message, TPS cs.cfg, cgi-bin/home/index.cgi and nss.conf (28.95 KB, application/zip)
2009-04-10 10:28 EDT, Sean Veale
no flags Details

  None (edit)
Description Sean Veale 2009-04-10 10:28:55 EDT
Created attachment 339095 [details]
Includes error message, TPS cs.cfg, cgi-bin/home/index.cgi and nss.conf 

Description of problem:
After setting up the the TPS server to use SSL communications by modifying the nss.conf file(per section 6.9.2 of the beta guide), cgi-bin/home/index.cgi and CS.cfg files (all attached in the zip) and downloading and installing into the browser(firefox) the certs chain that includes the root and sub ca  I get an error 

"The certificate is not trusted because the issuer is not trusted" error message and can't continue with a format. 

I set it up to use port 7890 (Or at least I believe I did) . 

Version-Release number of selected component (if applicable):


How reproducible:
Always 

Steps to Reproduce:
1. Modify the Tps configs per 6.9.2 of the beta docs, and other steps to add SSL over http support. 
2.Insert a blank token, so the test the phone home screen is displayed. Enter the url for the  https phone home. 
3.
  
Actual results:

Error message

Expected results:
Able to format and use cards. 

Additional info:
Comment 1 Sean Veale 2009-04-10 10:32:26 EDT
Should have said section 6.9.1 of the beta admin guide instead of 6.9.2

Note You need to log in before you can comment on or make changes to this bug.