Bug 495222 - python xml exchange example raise exception
python xml exchange example raise exception
Status: CLOSED WONTFIX
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: python-qpid (Show other bugs)
1.1
All Linux
medium Severity medium
: 1.3
: ---
Assigned To: Rafael H. Schloming
Martin Kudlej
:
: 558991 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-10 10:40 EDT by Martin Kudlej
Modified: 2014-12-01 18:14 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-24 13:03:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Kudlej 2009-04-10 10:40:06 EDT
Description of problem:
I tried to start declare_queues.py from rhm-docs python xml exchange example 
in rhts test and exception raised without loss of functionality.

Version-Release number of selected component (if applicable):
rhel 5.3/4.7 i386/x86_64 
rhm-docs-0.5.756148-1 
qpidc-0.5.752581-3
python-qpid-0.5.752581-1

How reproducible:
70%

Steps to Reproduce:
run 

for i in `seq 20`; do /usr/share/doc/rhm-0.5/python/xml-exchange/declare_queues.py; sleep 5; done

or run just

/usr/share/doc/rhm-0.5/python/xml-exchange/declare_queues.py

or 
/usr/share/doc/rhm-0.5/python/xml-exchange/declare_queues.py
qpid-config del queue message_queue
/usr/share/doc/rhm-0.5/python/xml-exchange/declare_queues.py

  
Actual results:
Exception in thread Thread-1 (most likely raised during interpreter shutdown):
Traceback (most recent call last):
  File "/usr/lib/python2.4/threading.py", line 442, in __bootstrap
  File "/usr/lib/python2.4/threading.py", line 422, in run
  File "/usr/lib/python2.4/site-packages/qpid/connection.py", line 172, in run
  File "/usr/lib/python2.4/site-packages/qpid/delegates.py", line 47, in received
  File "/usr/lib/python2.4/site-packages/qpid/delegates.py", line 91, in session_detached
  File "/usr/lib/python2.4/site-packages/qpid/connection.py", line 123, in detach
  File "/usr/lib/python2.4/threading.py", line 112, in release
exceptions.TypeError: 'NoneType' object is not callable
Unhandled exception in thread started by 
Error in sys.excepthook:

Original exception was:

Expected results:
No exception
Comment 2 Gordon Sim 2010-01-27 02:50:22 EST
*** Bug 558991 has been marked as a duplicate of this bug. ***
Comment 3 Gordon Sim 2010-01-27 02:51:07 EST
Updated stack trace from recently raised duplicate:

Exception in thread Thread-1 (most likely raised during interpreter shutdown):
Traceback (most recent call last):
  File "/usr/lib64/python2.6/threading.py", line 525, in __bootstrap_inner
  File "/usr/lib64/python2.6/threading.py", line 477, in run
  File "/usr/local/lib/python2.6/site-packages/qpid/connection.py", line 178,
in run
  File "/usr/local/lib/python2.6/site-packages/qpid/delegates.py", line 56, in
received
  File "/usr/local/lib/python2.6/site-packages/qpid/session.py", line 188, in
received
  File "/usr/local/lib/python2.6/site-packages/qpid/session.py", line 193, in
dispatch
  File "/usr/local/lib/python2.6/site-packages/qpid/session.py", line 308, in
message_transfer
<type 'exceptions.AttributeError'>: 'NoneType' object has no attribute 'debug'
Comment 4 Robert Rati 2010-05-13 15:39:29 EDT
Another stack trace from the configuration tools:

Exception in thread Thread-3 (most likely raised during interpreter shutdown):
Traceback (most recent call last):
  File "/usr/lib64/python2.6/threading.py", line 525, in __bootstrap_inner
  File "/usr/lib64/python2.6/threading.py", line 477, in run
  File "/usr/local/lib/python2.6/site-packages/qpid/queue.py", line 84, in run
  File "/usr/local/lib/python2.6/site-packages/qmf/console.py", line 2208, in _v1Cb
  File "/usr/local/lib/python2.6/site-packages/qmf/console.py", line 2257, in _v1CbProtected
  File "/usr/local/lib/python2.6/site-packages/qmf/console.py", line 892, in _handleClassInd
  File "/usr/local/lib/python2.6/site-packages/qmf/console.py", line 2154, in _send
  File "/usr/local/lib/python2.6/site-packages/qpid/generator.py", line 25, in <lambda>
  File "/usr/local/lib/python2.6/site-packages/qpid/session.py", line 138, in invoke
  File "/usr/local/lib/python2.6/site-packages/qpid/session.py", line 171, in do_invoke
  File "/usr/local/lib/python2.6/site-packages/qpid/session.py", line 204, in send
  File "/usr/local/lib/python2.6/site-packages/qpid/session.py", line 255, in send
  File "/usr/local/lib/python2.6/site-packages/qpid/connection.py", line 201, in write_op
  File "/usr/lib64/python2.6/threading.py", line 135, in release
<type 'exceptions.TypeError'>: 'NoneType' object is not callable
Comment 5 Matthew Farrellee 2010-06-07 09:20:30 EDT
Possibly same/similar - BZ587166
Comment 6 Rafael H. Schloming 2010-06-24 13:03:49 EDT
The problem here is simply that the examples don't close the connection, however these examples are deprecated and will be removed shortly, so there is no point in fixing them.

Note You need to log in before you can comment on or make changes to this bug.