Bug 495238 - gedit-plugins should be updated to 2.26.0 for Fedora 11
gedit-plugins should be updated to 2.26.0 for Fedora 11
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gedit-plugins (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Rakesh Pandit
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-10 13:03 EDT by Dodji Seketeli
Modified: 2009-04-11 13:41 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-11 10:59:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to update the patckage to 2.26 (1.88 KB, patch)
2009-04-10 13:03 EDT, Dodji Seketeli
no flags Details | Diff
Patch to build gedit-plugins 2.26.1 (2.69 KB, patch)
2009-04-11 09:39 EDT, Dodji Seketeli
no flags Details | Diff

  None (edit)
Description Dodji Seketeli 2009-04-10 13:03:23 EDT
Created attachment 339110 [details]
Patch to update the patckage to 2.26

The current package lags quite a bit with respected to upstream releases.
It's still at 2.22.3 when the upstream version is 2.26.0.

I built the 2.26 package and the koji task is http://koji.fedoraproject.org/koji/taskinfo?taskID=1289691.

I has been tested and seems to works great.

Please find the patched spec file below.

I couldn't update it in cvs myself as I don't have the needed rights on the package.
Comment 1 Dodji Seketeli 2009-04-11 06:13:53 EDT
PING ?

It's really important to get this in now, because the final freeze for Fedora 11 is next tuesday: https://www.redhat.com/archives/fedora-devel-list/2009-April/msg00642.html.
Comment 2 Rakesh Pandit 2009-04-11 06:23:28 EDT
I have been to much occupied by day job these days. :(

Thanks for patch .. will push it in an hour!
Comment 3 Rakesh Pandit 2009-04-11 06:27:21 EDT
I am sorry not in an hour .. but today for sure .. I need to set up my rawhide.
Comment 4 paolo borelli 2009-04-11 06:45:47 EDT
I'll just rolled a new 2.26.1 tarball since I saw that there is an important bugfix wrt 2.26.0. It would be great to get that one in
Comment 5 Dodji Seketeli 2009-04-11 07:34:24 EDT
(In reply to comment #2)
> I have been to much occupied by day job these days. :(

No problem :) Day job is what keeps up alive as well :)

> Thanks for patch .. will push it in an hour!

My pleasure. Thank you for following up.
Comment 6 Dodji Seketeli 2009-04-11 08:33:59 EDT
(In reply to comment #3)
> I am sorry not in an hour .. but today for sure .. I need to set up my rawhide.  

Okay. Please let me know if there is anything I could do to help.
Comment 7 Dodji Seketeli 2009-04-11 09:07:28 EDT
(In reply to comment #4)
> I'll just rolled a new 2.26.1 tarball since I saw that there is an important
> bugfix wrt 2.26.0. It would be great to get that one in  

Thank you, Paolo, for rolling that new release.

I have updated the spec file to build that new package.

Furthermore, as you noticed on IRC, there were a couple of *.la files that snuck into the package. The new spec file makes sure to remove all the *.la files there.

The koji task of the 2.26.1 build can be accessed at http://koji.fedoraproject.org/koji/taskinfo?taskID=1290890.

Please find below the patch to the spec file.

Rakesh, would you fancy push the 2.26.1 package instead ? :)

Thanks.
Comment 8 Rakesh Pandit 2009-04-11 09:37:25 EDT
> Rakesh, would you fancy push the 2.26.1 package instead ? :)

Yep :) Did you test it a bit ? .. will test it a bit and push .. just installed rawhide.
Comment 9 Dodji Seketeli 2009-04-11 09:39:20 EDT
Created attachment 339181 [details]
Patch to build gedit-plugins 2.26.1

Actually this patch also removes the now needless libgnomeui-devel BuildRequires.
Comment 10 Dodji Seketeli 2009-04-11 09:41:14 EDT
(In reply to comment #9)
> Created an attachment (id=339181) [details]
> Patch to build gedit-plugins 2.26.1
> 
> Actually this patch also removes the now needless libgnomeui-devel
> BuildRequires.  

Last koji task is http://koji.fedoraproject.org/koji/taskinfo?taskID=1290900 .
Comment 11 Dodji Seketeli 2009-04-11 09:47:43 EDT
(In reply to comment #8)
> > Rakesh, would you fancy push the 2.26.1 package instead ? :)
> 
> Yep :) Did you test it a bit ? .. will test it a bit and push .. just installed
> rawhide.  

Yes, Paolo tested it and said it was OK. Please note that I have updated the spec file and attached it above.

Thank you very much.
Comment 12 Rakesh Pandit 2009-04-11 10:59:29 EDT
Thanks Dodji .. I did tested .. and pushed and build .. thanks for your work!
Comment 13 Dodji Seketeli 2009-04-11 13:41:15 EDT
Thank you Rakesh !

Note You need to log in before you can comment on or make changes to this bug.