Bug 495276 - UPS known to hal but not recognised by gnome-power-manager
UPS known to hal but not recognised by gnome-power-manager
Status: CLOSED DUPLICATE of bug 504496
Product: Fedora
Classification: Fedora
Component: gnome-power-manager (Show other bugs)
10
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-10 23:24 EDT by brianchad@westnet.com.au
Modified: 2009-07-02 08:55 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-02 08:55:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description brianchad@westnet.com.au 2009-04-10 23:24:02 EDT
Description of problem:


UPS not recognised by gnome-power-manager, although hal seems to know about it

Version-Release number of selected component (if applicable):

all latest F10 updates


How reproducible:

all the time


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:


abbreviated output from lshal


udi = '/org/freedesktop/Hal/devices/usb_device_6da_3_noserial'
  info.bus = 'usb_device'  (string)
  info.linux.driver = 'usb'  (string)
  info.parent = '/org/freedesktop/Hal/devices/usb_device_1d6b_1_0000_00_13_1'  (string)
  info.product = 'USB UPS'  (string)
  info.subsystem = 'usb_device'  (string)
  info.udi = '/org/freedesktop/Hal/devices/usb_device_6da_3_noserial'  (string)
  info.vendor = 'Phoenixtec Power Co., Ltd'  (string)
  linux.device_file = '/dev/bus/usb/003/005'  (string)
  linux.hotplug_type = 2  (0x2)  (int)
  linux.subsystem = 'usb'  (string)
  linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:13.1/usb3/3-3'  (string)
  usb_device.bus_number = 3  (0x3)  (int)
  usb_device.can_wake_up = true  (bool)
  usb_device.configuration_value = 1  (0x1)  (int)
  usb_device.device_class = 0  (0x0)  (int)
  usb_device.device_protocol = 0  (0x0)  (int)
  usb_device.device_revision_bcd = 1024  (0x400)  (int)
  usb_device.device_subclass = 0  (0x0)  (int)
  usb_device.is_self_powered = false  (bool)
  usb_device.linux.device_number = 5  (0x5)  (int)
  usb_device.linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:13.1/usb3/3-3'  (string)
  usb_device.max_power = 100  (0x64)  (int)
  usb_device.num_configurations = 1  (0x1)  (int)
  usb_device.num_interfaces = 1  (0x1)  (int)
  usb_device.num_ports = 0  (0x0)  (int)
  usb_device.product = 'USB UPS'  (string)
  usb_device.product_id = 3  (0x3)  (int)
  usb_device.speed = 1.5 (1.5) (double)
  usb_device.vendor = 'Phoenixtec Power Co., Ltd'  (string)
  usb_device.vendor_id = 1754  (0x6da)  (int)
  usb_device.version = 1.1 (1.1) (double)

debug output of gnome-power-manager

** (gnome-power-manager:15437): WARNING **: This machine is not identified as a laptop.system.formfactor is desktop.

** (gnome-power-manager:15437): WARNING **: This machine is not identified as a laptop.system.formfactor is desktop.
Comment 1 Richard Hughes 2009-07-02 08:55:33 EDT

*** This bug has been marked as a duplicate of bug 504496 ***

Note You need to log in before you can comment on or make changes to this bug.