This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 495297 - KMS:RV250:Mobility FireGL 9000 Garbled screen on ThinkPad R50
KMS:RV250:Mobility FireGL 9000 Garbled screen on ThinkPad R50
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
11
i686 Linux
high Severity high
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-11 07:46 EDT by Thilo Mezger
Modified: 2015-12-05 09:24 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 07:48:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (841.97 KB, image/jpeg)
2009-04-11 07:46 EDT, Thilo Mezger
no flags Details
dmesg output (33.50 KB, text/plain)
2009-04-11 07:47 EDT, Thilo Mezger
no flags Details
lspci -vv output (11.63 KB, text/plain)
2009-04-11 07:48 EDT, Thilo Mezger
no flags Details
xorg.conf (407 bytes, text/plain)
2009-04-11 07:49 EDT, Thilo Mezger
no flags Details
/var/log/Xorg.0.log (29.06 KB, text/plain)
2009-04-11 07:49 EDT, Thilo Mezger
no flags Details
dmesg output with "nomodeset" (32.58 KB, text/plain)
2009-04-13 09:15 EDT, Thilo Mezger
no flags Details
Xorg.0.log with "nomodeset" (37.27 KB, text/plain)
2009-04-13 09:15 EDT, Thilo Mezger
no flags Details
Xorg.0.log from F10 (65.42 KB, text/plain)
2009-04-17 05:14 EDT, Thilo Mezger
no flags Details

  None (edit)
Description Thilo Mezger 2009-04-11 07:46:43 EDT
Created attachment 339170 [details]
screenshot

Description of problem:

I can't seem to get X11 running with F11-beta on my IBM ThinkPad R50 (model 1829-7RG) that has a built-in Radeon RV250 [Mobility FireGL 9000] card.  The screen is completely garbled as can be seen in screenshot.jpg.


Version-Release number of selected component (if applicable):

xorg-x11-drv-ati-6.12.1-10.fc11.i586
kernel-2.6.29.1-54.fc11.i586


How reproducible:

I've simply started X with or without an existing xorg.conf file by simply running command "X".  I've tried various options of the "radeon" driver - same result...

  
Actual results:

Garbled screen as can be seen in screenshot.jpg.


Expected results:

Proper display as it worked in F10.


Additional info:

Please find output of dmesg, lspci as well as xorg.conf and Xorg.0.log as attachment.
Comment 1 Thilo Mezger 2009-04-11 07:47:37 EDT
Created attachment 339171 [details]
dmesg output
Comment 2 Thilo Mezger 2009-04-11 07:48:23 EDT
Created attachment 339172 [details]
lspci -vv output
Comment 3 Thilo Mezger 2009-04-11 07:49:00 EDT
Created attachment 339173 [details]
xorg.conf
Comment 4 Thilo Mezger 2009-04-11 07:49:35 EDT
Created attachment 339174 [details]
/var/log/Xorg.0.log
Comment 5 François Cami 2009-04-11 22:35:03 EDT
Thilo,

Thanks for the bug report and the logs.
What happens if you add  nomodeset  to the kernel command line ?

---
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 Thilo Mezger 2009-04-13 09:12:33 EDT
Not much has changed when adding nomodeset - the pattern now looks slightly different.  So I won't upload a new screenshot but only add new dmesg and Xorg.0.log.
Comment 7 Thilo Mezger 2009-04-13 09:15:11 EDT
Created attachment 339316 [details]
dmesg output with "nomodeset"

This is a new kernel (2.6.29.1-68.fc11.i586) compared to the original posting.
Comment 8 Thilo Mezger 2009-04-13 09:15:52 EDT
Created attachment 339317 [details]
Xorg.0.log with "nomodeset"
Comment 9 François Cami 2009-04-14 17:39:35 EDT
Thanks for the additional logs. Thilo, if you still have that F10 install, the Xorg.0.log from F10 would help immensely there. Could you add it as well ?

Thanks in advance

---
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 10 Thilo Mezger 2009-04-17 05:14:39 EDT
Created attachment 339977 [details]
Xorg.0.log from F10

I've reinstalled F10 on this very notebook and applied all updates.  X runs pretty well again now but I noticed two EE's:

(EE) RADEON(0): Static buffer allocation failed.  Disabling DRI.
(EE) RADEON(0): At least 33600 kB of video memory needed at this resolution and depth.
Comment 11 François Cami 2009-04-17 06:47:24 EDT
Thanks for the logs.

---
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 12 Bug Zapper 2009-06-09 09:39:30 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 13 Matěj Cepl 2009-11-05 13:26:11 EST
Since this bugzilla report was filed, there have been several major updates in various components of the Xorg system, which may have resolved this issue. Users who have experienced this problem are encouraged to upgrade their system to the latest version of their packages. For packages from updates-testing repository you can use command

yum upgrade --enablerepo='*-updates-testing'

Alternatively, you can also try to test whether this bug is reproducible with the upcoming Fedora 12 distribution by downloading LiveMedia of F12 Beta available at http://alt.fedoraproject.org/pub/alt/nightly-composes/ . By using that you get all the latest packages without need to install anything on your computer. For more information on using LiveMedia take a look at https://fedoraproject.org/wiki/FedoraLiveCD .

Please, if you experience this problem on the up-to-date system, let us now in the comment for this bug, or whether the upgraded system works for you.

If you won't be able to reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[This is a bulk message for all open Fedora Rawhide Xorg-related bugs. I'm adding myself to the CC list for each bug, so I'll see any comments you make after this and do my best to make sure every issue gets proper attention.]
Comment 14 Matěj Cepl 2010-02-26 07:21:29 EST
Could you please reply to the previous question? If you won't reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[Note please, that this is machine generated comment for large amount of bugs; due to some technical issues, it is possible we've missed some of the responses -- it is happens, please, just a make a comment about that; that we will see. Thank you]
Comment 15 Bug Zapper 2010-04-27 09:37:52 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 16 Vedran Miletić 2010-05-24 15:01:24 EDT
Closing per comment 14.

---

Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

[This triage is part of collective effort done by students of University of
Rijeka Department of Informatics.]
Comment 17 Bug Zapper 2010-06-28 07:48:04 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.