Red Hat Bugzilla – Bug 495312
emacs-git should now require version 22
Last modified: 2013-01-10 05:31:57 EST
Using package git-22.214.171.124-1.fc11.src.rpm, only "emacs" is required for emacs-git, but in reality, the Git/emacs integration code no longer works with emacs 21, so the require should be "emacs >= 22.0".
This requirement is noted in the emacs-git README that is included in the emacs-git subpackage.
Fedora has had emacs >= 22.0 since at least F-7. Unless we want to unify the git spec file(s) for Fedora and EPEL, is there any reason to add a versioned requirement?
(1) It's easy.
(2) More specific dependency declarations will save somebody (else) trouble, somewhere, someday.
(3) Yeah, why not use the same specfile for EPEL? That's a good idea.
(4) I rebuild Fedora Git packages on RHEL 5 because the EPEL versions are too old, so for me specifically, this would've saved the problem that emacs-git prevented emacs from even starting because I didn't know about the version dependency which only changed between Fedora's Git 1.6.1 and 1.6.2 packages due to new emacs-git code. I'd like to save someone else the trouble of having to figure it out on their own if they run into the same problem.
(In reply to comment #2)
> (1) It's easy.
> (2) More specific dependency declarations will save somebody (else) trouble,
> somewhere, someday.
Sure. As long as it doesn't get outdated or cause the package maintainers much hassle to keep around. I suppose that while even ancient Fedora releases have a recent enough emacs, that there are many folks in your position who want to run git on RHEL and that may warrant a little effort to make that a little easier.
> (3) Yeah, why not use the same specfile for EPEL? That's a good idea.
I've thought about it. The git spec file has been around for a while, so it could use some general clean up. I haven't looked closely yet to see how much work it would be to conditionalize the spec file properly just yet. I don't think it would be too bad. I simply haven't made time to work on that.
> (4) I rebuild Fedora Git packages on RHEL 5 because the EPEL versions are too
> old, so for me specifically, this would've saved the problem that emacs-git
> prevented emacs from even starting because I didn't know about the version
> dependency which only changed between Fedora's Git 1.6.1 and 1.6.2 packages due
> to new emacs-git code. I'd like to save someone else the trouble of having to
> figure it out on their own if they run into the same problem.
So, contrib/emacs/README says:
This file used to contain the VC-mode backend for git, but it is no
longer distributed with git. It is now maintained as part of Emacs
and included in standard Emacs distributions starting from version
If you have an earlier Emacs version, upgrading to Emacs 22 is
recommended, since the VC mode in older Emacs is not generic enough
to be able to support git in a reasonable manner, and no attempt has
been made to backport vc-git.el.
I take that to mean that we should really have emacs >= 22.2 as the requirement. Is that correct, or is there a reason we can get away with using 22.0, as you wrote in your initial comment? It seems to me that if we're requiring a version for emacs, it ought to be one that will work out of the box.
Yes, good catch, you're right, it should be >= 22.2. I think I missed the .2 in my read as only 22 is mentioned in the second paragraph. But yeah, 22.2 looks right. Thanks!
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.
More information and reason for this action is here:
This was fixed in git-126.96.36.199-1 (in rawhide). Eventually, this will make it into F-11 as well.