Bug 49533 - Disk Druid does not properly identify SCSI disks
Summary: Disk Druid does not properly identify SCSI disks
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: parted (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Matt Wilson
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-20 14:55 UTC by greg hosler
Modified: 2007-04-18 16:34 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-21 20:18:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description greg hosler 2001-07-20 14:55:08 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.3-2.9.2smp i686)

Description of problem:
In installation, selectinf Disk Druid for partitioning and/or assigning
partitions,
Disk Druid displays Model as "Model: unknown SCSI".

In actual fact, a grep thru /proc/scsi/scsi will product the "Vendor: xxx,
Model: xxx"
string that could be substituted instead of the less appropriate "Unknown
SCSI"


How reproducible:
Always

Steps to Reproduce:
1. install 7.2 beta, on a SCSI based system (important that you have SCSI)
2. Select DISK DRUID for partition program.
3. Note that all SCSI disks display "Model: Unknown SCSI"

Note I have a AHA 29160, but as far as /proc/scsi/scsi goes, that doesn't
really matter.

	

Additional info:

Comment 1 Jay Turner 2002-03-21 15:05:48 UTC
I'm not able to replicate this in the test lab.  Are you still seeing this with
the recent Hampton betas?

Comment 2 Josep L. Guallar-Esteve 2002-03-21 20:18:53 UTC
Works here. 
 
At least with Skipjack-re0320.0 (beta 3), Disk Druid  displays 
proper disc models. 
 
Tested on a Compaq ML330, with a Symbios Logic 53c895a SCSI 
controller and 2 SCSI discs . Both discs models are displayed 
properly on Disk Druid (Model: COMPAQ PB00921...  Model: HP 
9.10 GB A ...)

Comment 3 greg hosler 2002-03-23 04:48:45 UTC
This was fixed during the RH7.2 beta cycle.

I have since verified it as still fixed in RH7.3


Note You need to log in before you can comment on or make changes to this bug.