Bug 495333 - ungrammatical syslog message
ungrammatical syslog message
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anacron (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-12 00:37 EDT by Jonathan Kamens
Modified: 2009-04-14 10:36 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-14 10:36:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2009-04-12 00:37:19 EDT
anacron sometimes logs "Normal exit (0 job run)".  It should say "jobs", not "job".
Comment 1 Marcela Mašláňová 2009-04-14 02:31:06 EDT
Do you have anacron-2.3-73.fc11.x86_64? In this final version it should be working correctly.
Comment 2 Jonathan Kamens 2009-04-14 09:39:17 EDT
Yes, I have the current version.  No, it does not solve the problem.  The problem is quite obvious:

    explain("Normal exit (%d job%s run)", njobs-dropped_jobs, (njobs == 1 ? "" : "s"));

It should say:

    explain("Normal exit (%d job%s run)", njobs-dropped_jobs, ((njobs-dropped_jobs) == 1 ? "" : "s"));
Comment 3 Marcela Mašláňová 2009-04-14 10:36:47 EDT
Thanks

Note You need to log in before you can comment on or make changes to this bug.