Bug 495334 - Cannot use some USB flash drives with Fedora 11 (Rawhide)
Cannot use some USB flash drives with Fedora 11 (Rawhide)
Status: CLOSED DUPLICATE of bug 494932
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-12 00:47 EDT by Florin Iucha
Modified: 2009-05-08 11:57 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-08 11:57:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Kernel message ring buffer. The last successful device is the Kingston. (70.57 KB, text/plain)
2009-04-12 00:47 EDT, Florin Iucha
no flags Details

  None (edit)
Description Florin Iucha 2009-04-12 00:47:22 EDT
Created attachment 339209 [details]
Kernel message ring buffer.  The last successful device is the Kingston.

Description of problem:

I am inserting my flash drive into an USB port and the kernel goes into a continuous loop of recognizing the device then failing to read something from somewhere and disconnecting it.  It happens with one of the two drives that I have, the other works as expected.  There is no problem with the hardware - I have installed System Rescue CD 1.1.7 on the problematic USB flash drive then booted from it and copied files around without problem.


Version-Release number of selected component (if applicable):

Linux hera.iucha.org 2.6.29.1-54.fc11.x86_64 #1 SMP Tue Apr 7 05:26:42 EDT 2009 x86_64 x86_64 x86_64 GNU/Linu

How reproducible:

Always, with one of the drives (A-Data JOGR 4GB).  Never with the other one (Kingston Data Traveller 1GB)

Steps to Reproduce:
1. Insert USB flash drive into USB port
2. Wait
3. Peek at the kernel message buffer with dmesg
  
Actual results:
usb 1-5: new high speed USB device using ehci_hcd and address 8
usb 1-5: New USB device found, idVendor=1307, idProduct=0163
usb 1-5: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 1-5: Product: USB Flash Drive
usb 1-5: Manufacturer: USB 2.0
usb 1-5: SerialNumber: 112730c7c18556
usb 1-5: configuration #1 chosen from 1 choice
Initializing USB Mass Storage driver...
scsi8 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 8
usb-storage: waiting for device to settle before scanning
usbcore: registered new interface driver usb-storage
USB Mass Storage support registered.
usb-storage: device scan complete
scsi 8:0:0:0: Direct-Access     USB 2.0  USB Flash Drive  0.00 PQ: 0 ANSI: 2
sd 8:0:0:0: [sdc] 7897087 512-byte hardware sectors: (4.04 GB/3.76 GiB)
sd 8:0:0:0: [sdc] Write Protect is off
sd 8:0:0:0: [sdc] Mode Sense: 00 00 00 00
sd 8:0:0:0: [sdc] Assuming drive cache: write through
sd 8:0:0:0: [sdc] 7897087 512-byte hardware sectors: (4.04 GB/3.76 GiB)
sd 8:0:0:0: [sdc] Write Protect is off
sd 8:0:0:0: [sdc] Mode Sense: 00 00 00 00
sd 8:0:0:0: [sdc] Assuming drive cache: write through
 sdc: sdc1
sd 8:0:0:0: [sdc] Attached SCSI removable disk
sd 8:0:0:0: Attached scsi generic sg3 type 0
sd 8:0:0:0: [sdc] 7897087 512-byte hardware sectors: (4.04 GB/3.76 GiB)
sd 8:0:0:0: [sdc] Write Protect is off
sd 8:0:0:0: [sdc] Mode Sense: 00 00 00 00
sd 8:0:0:0: [sdc] Assuming drive cache: write through
sd 8:0:0:0: [sdc] 7897087 512-byte hardware sectors: (4.04 GB/3.76 GiB)
sd 8:0:0:0: [sdc] Write Protect is off
sd 8:0:0:0: [sdc] Mode Sense: 00 00 00 00
sd 8:0:0:0: [sdc] Assuming drive cache: write through
 sdc:Dev sdc: unable to read RDB block 0
 unable to read partition table
sd 8:0:0:0: [sdc] 7897087 512-byte hardware sectors: (4.04 GB/3.76 GiB)
sd 8:0:0:0: [sdc] Write Protect is off
sd 8:0:0:0: [sdc] Mode Sense: 00 00 00 00
sd 8:0:0:0: [sdc] Assuming drive cache: write through
sd 8:0:0:0: [sdc] 7897087 512-byte hardware sectors: (4.04 GB/3.76 GiB)
sd 8:0:0:0: [sdc] Write Protect is off
sd 8:0:0:0: [sdc] Mode Sense: 00 00 00 00
sd 8:0:0:0: [sdc] Assuming drive cache: write through
 sdc:Dev sdc: unable to read RDB block 0
 unable to read partition table

Expected results:

usb 1-5: new high speed USB device using ehci_hcd and address 9
usb 1-5: New USB device found, idVendor=0951, idProduct=1603
usb 1-5: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 1-5: Product: DataTraveler 2.00000031305
usb 1-5: Manufacturer: Kingston
usb 1-5: SerialNumber: 0000031305
usb 1-5: configuration #1 chosen from 1 choice
scsi9 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 9
usb-storage: waiting for device to settle before scanning
usb-storage: device scan complete
scsi 9:0:0:0: Direct-Access     Kingston DataTraveler 2.0 1.00 PQ: 0 ANSI: 2
sd 9:0:0:0: [sdc] 1952256 512-byte hardware sectors: (999 MB/953 MiB)
sd 9:0:0:0: [sdc] Write Protect is off
sd 9:0:0:0: [sdc] Mode Sense: 03 00 00 00
sd 9:0:0:0: [sdc] Assuming drive cache: write through
sd 9:0:0:0: [sdc] 1952256 512-byte hardware sectors: (999 MB/953 MiB)
sd 9:0:0:0: [sdc] Write Protect is off
sd 9:0:0:0: [sdc] Mode Sense: 03 00 00 00
sd 9:0:0:0: [sdc] Assuming drive cache: write through
 sdc: sdc4
sd 9:0:0:0: [sdc] Attached SCSI removable disk
sd 9:0:0:0: Attached scsi generic sg3 type 0




Additional info:
Comment 1 J.F. Prieur 2009-05-04 13:58:03 EDT
Have the same problem as well, here is my log for the unsuccessful USB key:

usb 1-3: new high speed USB device using ehci_hcd and address 5
usb 1-3: New USB device found, idVendor=1307, idProduct=0163
usb 1-3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 1-3: Product: Flash Disk
usb 1-3: Manufacturer: USB 2.0
usb 1-3: SerialNumber: 3ca0c1b2658722
usb 1-3: configuration #1 chosen from 1 choice
scsi 8 : SCSI emulation for USB Mass Storage devices
scsi 8:0:0:0: Direct-Access     USB 2.0  Flash Disk       0.00 PQ: 0 ANSI: 2
sd 8:0:0:0: [sdb] 1974271 512-byte hardware sectors: (1.01 GB/963 MiB)
sd 8:0:0:0: [sdb] Write Protect is off
sd 8:0:0:0: [sdb] Assuming drive cache: write through
sd 8:0:0:0: [sdb] 1974271 512-byte hardware sectors: (1.01 GB/963 MiB)
sd 8:0:0:0: [sdb] Write Protect is off
sd 8:0:0:0: [sdb] Assuming drive cache: write through
sdb: sdb1
sd 8:0:0:0: [sdb] Attached SCSI removable disk
sd 8:0:0:0: Attached scsi generic sg2 type 0
sd 8:0:0:0: [sdb] 1974271 512-byte hardware sectors: (1.01 GB/963 MiB)
sd 8:0:0:0: [sdb] Write Protect is off
sd 8:0:0:0: [sdb] Assuming drive cache: write through
sd 8:0:0:0: [sdb] 1974271 512-byte hardware sectors: (1.01 GB/963 MiB)
sd 8:0:0:0: [sdb] Write Protect is off
sd 8:0:0:0: [sdb] Assuming drive cache: write through
sdb:Dev sdb: unable to read RDB block 0
unable to read partition table

Here is the log for the USB key that functions correctly:

usb 1-3: new high speed USB device using ehci_hcd and address 6
usb 1-3: New USB device found, idVendor=058f, idProduct=6387
usb 1-3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 1-3: Product: Mass Storage
usb 1-3: Manufacturer: Generic
usb 1-3: SerialNumber: 7564D9FE9105DBD52D8E
usb 1-3: configuration #1 chosen from 1 choice
scsi9 : SCSI emulation for USB Mass Storage devices
scsi 9:0:0:0: Direct-Access     Generic  Flash Disk       8.07 PQ: 0 ANSI: 2
sd 9:0:0:0: [sdb] 4102144 512-byte hardware sectors: (2.10 GB/1.95 GiB)
sd 9:0:0:0: [sdb] Write Protect is off
sd 9:0:0:0: [sdb] Assuming drive cache: write through
sd 9:0:0:0: [sdb] 4102144 512-byte hardware sectors: (2.10 GB/1.95 GiB)
sd 9:0:0:0: [sdb] Write Protect is off
sd 9:0:0:0: [sdb] Assuming drive cache: write through
adb:
sd 9:0:0:0: [sdb] Attached SCSI removable disk
sd 9:0:0:0: Attached scsi generic sg2 type 0

Both the keys mount with no problems on a Fedora 8 machine.
Comment 2 J.F. Prieur 2009-05-04 13:59:35 EDT
My apologies, forgot to add the Fedora 11 specs:

Linux 2.6.29.1-111.fc11.x86_64 #1 SMP Fri Apr 24 10:57:09 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux
Comment 3 Chuck Ebbert 2009-05-08 11:57:12 EDT

*** This bug has been marked as a duplicate of bug 494932 ***

Note You need to log in before you can comment on or make changes to this bug.