Bug 495397 - No networking for dbus enabled applications when having a bridge configured
No networking for dbus enabled applications when having a bridge configured
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-12 14:36 EDT by Andreas Thienemann
Modified: 2009-04-14 22:02 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-14 22:02:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 546197 None None None Never

  None (edit)
Description Andreas Thienemann 2009-04-12 14:36:58 EDT
System with the following bridge configuration:

[root@localhost network-scripts]# cat /etc/sysconfig/network-scripts/ifcfg-eth0
# Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller
DEVICE=eth0
BOOTPROTO=static
BRIDGE=br0
HWADDR=00:12:41:51:26:15
ONBOOT=yes
[root@localhost network-scripts]# cat /etc/sysconfig/network-scripts/ifcfg-br0 
DEVICE=br0
BOOTPROTO=dhcp
ONBOOT=yes
TYPE=Bridge
[root@localhost network-scripts]# 


When starting any dbus enabled application, network is disabled e.g. Offline Mode in Firefox.

Expected Result:
Working Firefox.

Affected versions:
[root@localhost ~]# rpm -q firefox dbus NetworkManager initscripts
firefox-3.1-0.11.beta3.fc11.x86_64
dbus-1.2.12-1.fc11.x86_64
NetworkManager-0.7.0.100-2.git20090408.fc11.x86_64
initscripts-8.94-1.x86_64
[root@localhost ~]#
Comment 1 Dan Williams 2009-04-12 18:30:32 EDT
Is the bridged device your primary network connection?  If so, you probably want to turn off NetworkManager.  NM is intended to control your primary network connection, and if it cannot, it of course won't think you're online, and thus the apps that use it wont either.
Comment 2 Andreas Thienemann 2009-04-12 18:59:19 EDT
Yeah, the bridge is the primary connection.

Interestingly, NM does see it as a "real" interface as soon as the TYPE=Bridge variable is removed and successfully get's a dhcp lease.

So the restriction "bridge not supported, disable NM" seems rather artificial.

But does disabling NM stop prevening dbus enabled apps from working?
Comment 3 Dan Williams 2009-04-14 22:02:30 EDT
(In reply to comment #2)
> Yeah, the bridge is the primary connection.
> 
> Interestingly, NM does see it as a "real" interface as soon as the TYPE=Bridge
> variable is removed and successfully get's a dhcp lease.
> 
> So the restriction "bridge not supported, disable NM" seems rather artificial.

It's not artificial, because something has to set up the actual bridge device and add ethX to the bridge.  And since that's not NetworkManager, NM doesn't support bridge connections.

For now, I'd suggest turning NM off since it cannot control your primary network connection.

-> UPSTREAM since the feature is being tracked there

Note You need to log in before you can comment on or make changes to this bug.