Bug 495430 - www.smolts.org website doesn't escape '/' in hardware links
www.smolts.org website doesn't escape '/' in hardware links
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: smolt (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Mike McGrath
Fedora Extras Quality Assurance
http://www.smolts.org/client/show/pub...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-13 00:04 EDT by Dariusz Garbowski
Modified: 2010-01-26 14:14 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-26 14:14:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dariusz Garbowski 2009-04-13 00:04:37 EDT
Description of problem:
www.smolts.org website doesn't escape '/' in hardware links. This results in failed searches/incorrectly working links.

Steps to Reproduce:
1. Go to th link in URL associated with this bug report.
2. Click on "Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller"
3. The page displayed will be at URL

http://www.smolts.org/reports/view_device/K8%20%5BAthlon64/Opteron%5D%20DRAM%20Controller

Notice the '/' between "Athlon64" and "Opteron" -- it should have been escaped like the spaces and brackets.
  
Actual results:
The search failed, displayed result for non existing device:

"Devices Found: Opteron] DRAM Controller"

Expected results:
Page with results of the search for "Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller".

Additional info:
Don't know if the report belongs here but since www.smolts.org doesn't seem to have "About", "Contact Us" or anything along those lines here's the report.
Comment 1 Bug Zapper 2009-06-09 09:43:08 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Sebastian Krämer 2010-01-19 14:12:39 EST
I noticed that too today. It's really not possible to link device pages that way (or at all??) :(
Comment 3 Mike McGrath 2010-01-26 14:14:12 EST
This is fixed upstream now, expecting to have a release out by the end of the week.

Note You need to log in before you can comment on or make changes to this bug.