Bug 495435 - exec "init 7" and the tty will hang
exec "init 7" and the tty will hang
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: SysVinit (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: Bill Nottingham
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-13 02:37 EDT by Yunlin Fang
Modified: 2014-03-16 23:18 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-14 13:27:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yunlin Fang 2009-04-13 02:37:29 EDT
Description of problem:


Version-Release number of selected component (if applicable):
Red Hat Enterprise Linux 5.2 and 5.3

How reproducible:
run a terminal at tty 1 -6 or X11, not ssh and other remote login.
and exec command "init 7",
then you will see system hang here.
tty 1- 7 stop. 
you can not press anything, but server still run. you can ssh to the server.


Steps to Reproduce:
1.run command: init 7
2.
3.
  
Actual results:
system hang

Expected results:
init tell no this runlevel and quit.

Additional info:

init will stop the tty that current runlevel opened, then open the tty that new runlevel setted .
/etc/inittab has no information about runlevel 7 8 9,so after you exec runlevel 7 8 9,system will stop the tty current level open, but do nothing action to init the new runlevel's tty.


I think you kan add a "if" to check the new runlevel wether is setting, if no, tell user and quit.
Comment 1 Bill Nottingham 2009-04-14 13:27:36 EDT
7-9 are valid runlevels as far as init is concerned; if there's nothing configured for them, it will run nothing.
Comment 2 Yunlin Fang 2009-04-14 21:25:04 EDT
(In reply to comment #1)
> 7-9 are valid runlevels as far as init is concerned; if there's nothing
> configured for them, it will run nothing.  

==
I don't think so.
I try it on my computer,
tty 1 to 7 will stop.(Like hang)
But other like service , network still OK .
Comment 3 Bill Nottingham 2009-04-15 11:31:41 EDT
Correct, because there's nothing that says network should be stopped in runlevel 7.

Note You need to log in before you can comment on or make changes to this bug.