Bug 495445 - Spacewalk fails to handle packages with the plus (+) sign in their name
Spacewalk fails to handle packages with the plus (+) sign in their name
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Release (Show other bugs)
0.5
All Linux
low Severity high
: ---
: ---
Assigned To: Clifford Perry
Brandon Perkins
:
Depends On:
Blocks: space06
  Show dependency treegraph
 
Reported: 2009-04-13 05:00 EDT by Alexandros Soumplis
Modified: 2012-03-06 04:01 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-27 09:08:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandros Soumplis 2009-04-13 05:00:19 EDT
Description of problem:
Spacewalk fails to handle packages which include the plus (+) sign in their names.

Version-Release number of selected component (if applicable):
0.5

How reproducible:
Every time

Steps to Reproduce:
1. Push the package libstdc++-4.1.2-44 (it happens with any package with the + sign in its name) into spacewalk
[root@andromeda CentOS]# rhnpush -vvvvvvvvvvvvvvvvvvv --force --channel=centos-5-base --server=https://andromeda.local.domain/APP  --username=xxxx --password='xxxx' libstdc++-4.1.2-44.el5.x86_64.rpm
Connecting to https://andromeda.local.domain/APP
url is https://andromeda.local.domain/PACKAGE-PUSH
Result codes: 200 OK
Computing md5sum and package Info .This may take sometime ...
Uploading package libstdc++-4.1.2-44.el5.x86_64.rpm
Using POST request


2. Login into spacewalk webui
3. Search for the package and try to download it (you can also try to install it to a client, its the same as this is not a problem of the web ui).
4. Error 404 occurs and package not found. 
  
Actual results:
The package fails to be found and downloaded from spacewalk although it exists in the repository.
Comment 1 shaun.rampersad 2009-06-02 06:35:52 EDT
I can confirm this when trying to upgrade my Centos server

[root@mrp-test3 packages]# yum update
Loading "fastestmirror" plugin
Loading "rhnplugin" plugin
Loading mirror speeds from cached hostfile
 * centos-x86_64-server-5: spacewalk.rmb.co.za
centos-x86_64-server-5    100% |=========================|  871 B    00:00     
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package glx-utils.x86_64 0:6.5.1-7.7.el5 set to be updated
---> Package xorg-x11-server-Xorg.x86_64 0:1.1.1-48.52.el5 set to be updated
---> Package mesa-libGL.i386 0:6.5.1-7.7.el5 set to be updated
---> Package kudzu.x86_64 0:1.2.57.1.21-1.el5.centos set to be updated
---> Package nss.i386 0:3.12.2.0-2.el5.centos set to be updated
---> Package firstboot-tui.x86_64 0:1.4.27.7-1.el5.centos set to be updated
.
.
. <snip>
.
.
.
--> Processing Dependency: libstdc++-devel = 4.1.2-44.el5 for package: gcc-c++
--> Processing Dependency: libstdc++ = 4.1.2-44.el5 for package: gcc-c++
--> Processing Dependency: gcc = 4.1.2-44.el5 for package: gcc-c++
--> Finished Dependency Resolution
Error: Missing Dependency: libgcj = 4.1.2-44.el5 is needed by package libgcj-devel
Error: Missing Dependency: libstdc++ = 4.1.2-44.el5 is needed by package libstdc++-devel
Error: Missing Dependency: libstdc++ = 4.1.2-44.el5 is needed by package gcc-c++
Error: Missing Dependency: gcc = 4.1.2-44.el5 is needed by package gcc-gfortran
Error: Missing Dependency: libgcj = 4.1.2-44.el5 is needed by package libgcj-src
Error: Missing Dependency: cpp = 4.1.2-44.el5 is needed by package gcc
Error: Missing Dependency: libgcj-devel = 4.1.2-44.el5 is needed by package gcc-java
Error: Missing Dependency: libgfortran = 4.1.2-44.el5 is needed by package gcc-gfortran
Error: Missing Dependency: libgcc >= 4.1.2-44.el5 is needed by package gcc
Error: Missing Dependency: gcc = 4.1.2-44.el5 is needed by package gcc-java
Error: Missing Dependency: libgcj = 4.1.2-44.el5 is needed by package gcc-java
Error: Missing Dependency: libstdc++-devel = 4.1.2-44.el5 is needed by package gcc-c++
Error: Missing Dependency: gcc = 4.1.2-44.el5 is needed by package gcc-c++

Any package that has a "+" in the name is not found.

Is there any temporary resolution around this as I have over 10 servers I need to update using spacewalk.
Comment 2 Devan Goodwin 2009-07-23 09:15:42 EDT
I believe this has been fixed some time ago. Just verified that libstdc++ packages are imported, visible in the web UI, and can be yum installed on a registered client system.

Moving to verified.

Note You need to log in before you can comment on or make changes to this bug.