Bug 495457 - No mouse arrow visible
No mouse arrow visible
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: tigervnc (Show other bugs)
11
All Linux
low Severity high
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
: 495456 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-13 06:17 EDT by Steve
Modified: 2013-04-30 19:42 EDT (History)
4 users (show)

See Also:
Fixed In Version: 0.0.91-0.11.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-24 15:43:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Log File of VineServer (2.14 KB, application/octet-stream)
2009-04-21 08:56 EDT, Steve
no flags Details

  None (edit)
Description Steve 2009-04-13 06:17:24 EDT
Description of problem:
The mouse arrow ist working (if you click anywhere) but not visible.

Version-Release number of selected component (if applicable):
tigervnc-0.0.90-0.5.20090403svn3751.fc11.i586
xorg-x11-drv-radeonhd-1.2.5-2.8.20090411git.fc11.i586

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:
The mouse arrow shoud be visible

Additional info:
Comment 1 Adam Tkac 2009-04-14 03:35:49 EDT
*** Bug 495456 has been marked as a duplicate of this bug. ***
Comment 2 Adam Tkac 2009-04-21 08:33:49 EDT
Could you tell me which client are you using, please? Also run vnc server with "-log *:stderr:100" parameter and attach log from the server, please (if you run, for example, "vncserver :3 -log *:stderr:100" then log is located in $HOME/.vnc/*:5.log file)
Comment 3 Steve 2009-04-21 08:56:27 EDT
Created attachment 340513 [details]
Log File of VineServer

There is no useful information in the server log file, because it's a mac.

Client is tigervnc-0.0.90-0.5.20090403svn3751.fc11.i586
Server is VineServer 3.0 (MacOS X)

VNC Viewer (vnc-4.1.3-1.fc10.i386) has no problem with the Server.
Comment 4 Steve 2009-05-07 08:38:50 EDT
If you disable "Render cursor locally", you will see only a dot, but the mouse is working.
Comment 5 Steve 2009-05-19 12:58:42 EDT
Switching back to RealVNC (http://www.realvnc.com/) solves the problem temporary.
Comment 6 Steve 2009-05-24 05:06:18 EDT
No changes in tigervnc-0.0.90-0.10.fc11.i586.
Comment 7 Scott Robbins 2009-05-29 17:36:37 EDT
Same issue with x86_64 version.  No mouse available--using Steve's suggestion of unchecking Render cursor locally works as he described. 

In my case, I used tightvnc (rather than real) and that solves the problem.
Comment 8 Bug Zapper 2009-06-09 09:44:13 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Scott Robbins 2009-06-13 18:26:49 EDT
The same problem exists in Fedora 12. I can reproduce it on a few different machines, running i386 and x86_64, whether running F11 or F12.
Comment 10 Scott Robbins 2009-06-14 01:00:02 EDT
This is apparently an upstream issue. I tried building it from source in Fedora and Ubuntu and had the same problem as with the RPM.
Comment 11 Adam Tkac 2009-06-18 08:40:29 EDT
Finally I got Mac machine so I've been able to reproduce this issue.
Comment 12 Fedora Update System 2009-06-22 08:46:39 EDT
tigervnc-0.0.91-0.11.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/tigervnc-0.0.91-0.11.fc11
Comment 13 Steve 2009-06-22 09:04:03 EDT
Yep, fixed for me, thx!
Comment 14 Scott Robbins 2009-06-22 10:41:37 EDT
Fixed it for me on an F11 x86_64 machine.  Thank you.
Comment 15 Scott Robbins 2009-06-22 19:28:29 EDT
Just for the heck of it, I tried the new F11 rpm on an F12 install.  The new  build installed without problem and fixed the problem there as well. 

Once again, many thanks.
Comment 16 Fedora Update System 2009-06-24 15:43:06 EDT
tigervnc-0.0.91-0.11.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.