Bug 495459 - Cooling fan keeps oscillating.
Cooling fan keeps oscillating.
Status: CLOSED DUPLICATE of bug 495259
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-13 06:19 EDT by Robert P. J. Day
Modified: 2009-04-13 13:01 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-13 13:01:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert P. J. Day 2009-04-13 06:19:14 EDT
Once my F11 beta system is up and running, the cooling fan on the system oscillates regularly between fast and slow, with about a 4-second cycle.  Occasionally, it will level out, but will quickly return to oscillating.

I have no idea if this is the right component to register it against.  Here's my smolt profile:

http://www.smolts.org/client/show/pub_27661e7f-528e-4db6-9ba4-8ce692a3ddf6
Comment 1 Jarod Wilson 2009-04-13 09:56:35 EDT
All cpuspeed does in the case of your system is make sure powernow-k8 is loaded and sets the governor to ondemand, so if there's an issue, its more likely a kernel one.

However... You've not yet given a convincing argument that the software is actually doing anything wrong. :) If your system is running hot for some reason (dust clogging an air intake or some such thing), its entirely possible the software is doing what's necessary to keep the system from overheating. Would also be good to know if this is new behavior that isn't seen if you boot into an older kernel. I'd suggest rebooting the current kernel with the added kernel param 'cpufreq.debug=7', and collecting dmesg output to attach here after a few oscillations, and from that, perhaps we'll have a better idea of why the fan keeps kicking in. Also, check for dust bunnies (it *was* Easter Sunday yesterday and all... ;) or other possible reasons it might be running hot.
Comment 2 Robert P. J. Day 2009-04-13 10:09:43 EDT
A couple of extra points.  First, this is a brand new laptop -- just out of the box last week, so it's unlikely it's had time to build up any dust bunnies. :-)

Also, as a comparative test, if I boot and hop into the BIOS, I can let it sit there arbitrarily long and the fan runs smoothly the whole time.  Only when I finally boot into F11 beta does the fan start oscillating again.

I'll do the cpufreq.debug and post the results in a bit.
Comment 3 Chuck Ebbert 2009-04-13 12:20:19 EDT
Wasn't this already reported as bug 495259?
Comment 4 Robert P. J. Day 2009-04-13 12:45:54 EDT
Whoops, quite right ... feel free to mark it as a duplicate if you want.
Comment 5 Jarod Wilson 2009-04-13 13:01:18 EDT

*** This bug has been marked as a duplicate of bug 495259 ***

Note You need to log in before you can comment on or make changes to this bug.