Bug 495487 - since qt4.5 qdevelop doesn't work
since qt4.5 qdevelop doesn't work
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: qdevelop (Show other bugs)
10
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Nicoleau Fabien
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-13 08:35 EDT by hcoohb
Modified: 2009-04-14 12:15 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-14 12:15:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description hcoohb 2009-04-13 08:35:12 EDT
Description of problem:
Since the upgrade to qt4.5 in fedroa10.
The program qdevelop doesn't work properly.
It freezes when I try to see the ".h" of a project (initially done with qt4.4)

Version-Release number of selected component (if applicable):
qdevelop from repositery v0.27


How reproducible:
always


Steps to Reproduce:
1.open qdevelop
2.open an old project
3.try to see the source code
  
Actual results:
The program doesn't respond and freeze using 50% CPU

Expected results:
To show the source code


Additional info:
Comment 1 Nicoleau Fabien 2009-04-14 07:08:21 EDT
Qt 4.5 is actually in testing repository.
btw, can you confirm that you are using 0.27.4 ? 
Can you do the same test with a new project ?

If the problem comes from new Qt version, please try the RPM coresponding to your architecture from this koji build : 
http://koji.fedoraproject.org/koji/taskinfo?taskID=1296980

This version is builded with new Qt version.
Comment 2 hcoohb 2009-04-14 09:00:08 EDT
Hello,

Yes, I have the kde-redhat-testing and kde-redhat-testing-all repositories enable.
The Qdevelop version currently installed on my system is : qdevelop-0.27.4-1.fc10(i386).

I tried to make a new project and as soon as I want to see the source code of a file, the program freezes. (exactly the same thing that for an existing project)
Comment 3 hcoohb 2009-04-14 09:06:06 EDT
I just download ans installed the RPM : qdevelop-0.27.4-1.fc11(i586).
And apparently the problem is solved !!
Opening my existing project and making a new one doesn't crash the program anymore.

Thank you  !
Comment 4 Nicoleau Fabien 2009-04-14 12:15:21 EDT
Ok, 
thank you for the feedback.

I'll build a new release with Qt 4.5 when it will be available in stable repositories.

Note You need to log in before you can comment on or make changes to this bug.