Bug 495530 - remove rpmlint warning on mixed spaces vs tabs
remove rpmlint warning on mixed spaces vs tabs
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rpmlint (Show other bugs)
10
All Linux
low Severity low
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-13 13:35 EDT by Matt Domsch
Modified: 2009-04-13 16:35 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-13 16:35:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Domsch 2009-04-13 13:35:33 EDT
Description of problem:
rpmlint throws a warning when a spec file contains both spaces and tabs to separate the tags from the tag data.

RPM itself doesn't care, they're both whitespace.  

Reviews get held up by package reviewers, over this simple (and completely useless) warning.  The specfile will be perfectly legible, but because rpmlint throws a warning, the review stalls.

https://bugzilla.redhat.com/show_bug.cgi?id=492181
is an example of one such review.

Please remove this useless, and in fact non-productive, warning.

Version-Release number of selected component (if applicable):
rpmlint-0.87-1.fc10.noarch
Additional info:
Comment 1 Ville Skyttä 2009-04-13 16:35:16 EDT
No, the warning will not be removed, it encourages one aspect of clean specfile writing style.  People who dislike it can filter it out in their rpmlint configs.  Reviewers who reject/stall package reviews because of this warning need to be educated to apply common sense in case the specfile is legible enough despite the warning.

Note You need to log in before you can comment on or make changes to this bug.