Bug 495545 - --orgid= results in Package not found error
--orgid= results in Package not found error
Status: CLOSED NOTABUG
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Satellite Synchronization (Show other bugs)
530
All Linux
low Severity high
: ---
: ---
Assigned To: Pradeep Kilambi
Jeff Browning
:
Depends On:
Blocks: 457071
  Show dependency treegraph
 
Reported: 2009-04-13 15:02 EDT by Jeff Browning
Modified: 2009-08-07 11:59 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-14 10:52:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Browning 2009-04-13 15:02:21 EDT
Description of problem:
When syncing from a Master to a Slave, and when syncing to an Org ID other than the base org, the sync fails with a Package Note Found error. Syncing the exact same channel to the base org of the slave works fine. It is only when syncing using the --orgid= variable.

Version-Release number of selected component (if applicable):
Satellite-5.3.0-RHEL5-re20090403.2-x86_64-embedded-oracle.iso

How reproducible:
100%

Steps to Reproduce:
1. Set up a Master and Slave satellite configuration (assuming Slave is configured to sync from the Master by default)
2. Set up an Org2 on the Slave (assuming Org ID = 2 for this example)
3. On Slave: # satellite-sync --orgid=2 -c<channel name>
  
Actual results:
18:22:10
SYNC ERROR:

Exception reported from test03-64.rhndev.redhat.com
Time: Mon Apr 13 18:22:10 2009
Exception type satellite_tools.syncLib.RhnSyncException

Exception Handler Information
Traceback (most recent call last):
  File "/usr/bin/satellite-sync", line 142, in main
    return satsync.Runner().main()
  File "/usr/share/rhn/satellite_tools/satsync.py", line 211, in main
    ret = method()
  File "/usr/share/rhn/satellite_tools/satsync.py", line 313, in _step_rpms
    self._packages_report = self.syncer.download_rpms()
  File "/usr/share/rhn/satellite_tools/satsync.py", line 1025, in download_rpms
    self._fetch_packages(channel, missing_fs_packages)
  File "/usr/share/rhn/satellite_tools/satsync.py", line 1822, in _fetch_packages
    package_id, nvrea, sources)
  File "/usr/share/rhn/satellite_tools/satsync.py", line 1905, in _get_package_stream
    stream  = self.xmlWireServer.getRpm(nvrea, channel)
  File "/usr/share/rhn/satellite_tools/xmlWireSource.py", line 266, in getRpm
    (self.systemid, package_name, channel))
  File "/usr/share/rhn/satellite_tools/xmlWireSource.py", line 170, in _openSocketStream
    raise RhnSyncException, lastErrorMsg
RhnSyncException:
Error Message:
    Package not found
Error Class Code: 17
Error Class Info: File not found.
Explanation:
     An error has occurred while processing your request. If this problem
     persists please enter a bug report at bugzilla.redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what you were trying to do when this error occurred and
     details on how to reproduce this problem.

Expected results:
The channel should sync to the specified Org on the slave satellite.

Additional info:
Slaves used: fjs-0-01 and test03-64
Master used: rlx-0-06

Please note, again, that the same channel works when syncing without the --orgid variable.
Comment 1 Pradeep Kilambi 2009-04-14 10:52:21 EDT
When you're running with a --orgid flag its trying to fetch the rpm but from what I saw on your master satellite(rlx-0-06) your /var/satellite is indeed missing those packages. I dint see a NULL directory at all for the base channels. 

The package was indeed missing from master satellites file system. Probably due to the issues on dump-new. I remounted dump-new on rlx-0-06  

Should now all be working with fixed dump-new mounts,

[root@test03-64 ~]# satellite-sync -c rhel-i386-server-5 --orgid=2

14:34:26 Downloading rpm packages
14:34:26    Fetching any missing RPMs: rhel-i386-server-5 (4072)
14:34:30       1/4072 Fetch successful: tetex-fonts-3.0-33.2.el5_1.2.i386.rpm (30680174 bytes)
14:34:31       2/4072 Fetch successful: tetex-xdvi-3.0-33.2.el5_1.2.i386.rpm (855944 bytes)

Note You need to log in before you can comment on or make changes to this bug.