Bug 495562 - suspend terminates current session
suspend terminates current session
Status: CLOSED DUPLICATE of bug 495497
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-13 15:59 EDT by Mads Villadsen
Modified: 2009-04-21 18:29 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-21 18:29:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg log file (53.49 KB, text/plain)
2009-04-13 16:01 EDT, Mads Villadsen
no flags Details

  None (edit)
Description Mads Villadsen 2009-04-13 15:59:56 EDT
Description of problem:
After resuming from suspend I am returned to the GDM login box instead of ending up were I suspended - ie. my session and all my open applications have been killed and I have to log in again.

This is on a Dell Latitude D820. Smolt hw info: http://www.smolts.org/show?uuid=pub_6b4f0342-3fc5-4335-afdd-fdfc4749b0c4

I am running without an xorg.conf.

Version-Release number of selected component (if applicable):
xorg-x11-drv-intel-2.6.99.902-2.fc11.i586

How reproducible:
Always

Steps to Reproduce:
1. Suspend
2. Resume
3. See GDM login window
  
Actual results:
Session gets killed

Expected results:
Session should be resumed
Comment 1 Mads Villadsen 2009-04-13 16:01:36 EDT
Created attachment 339368 [details]
xorg log file
Comment 2 Adam Williamson 2009-04-16 17:27:49 EDT
Sounds very similar to https://bugzilla.redhat.com/show_bug.cgi?id=495497 - can you tell from the information in that report if yours is a duplicate of it? Thanks!

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 cje 2009-04-17 07:14:04 EDT
i was getting this symptom with rawhide on my eeepc 901 (intel graphics) until just the other day but it looks like it's working okay at the moment.  only one suspend so far though (preceded by one weird graphics lockup, unfortunately).
Comment 4 Michael Monreal 2009-04-17 14:18:40 EDT
I'm seeing the same.
Comment 5 cje 2009-04-17 20:05:55 EDT
bother.  yeah, it just logged me out again too.
Comment 6 Hezekiah M. Carty 2009-04-21 10:49:26 EDT
(In reply to comment #2)
> Sounds very similar to https://bugzilla.redhat.com/show_bug.cgi?id=495497 - can
> you tell from the information in that report if yours is a duplicate of it?
> Thanks!

I do have the same or very similar content in my .xsession-errors file after the suspend/resume + X/GDM restart cycle.  So for me (Thinkpad R61, Intel GM965, latest rawhide as of Apr. 19 updates) the problem looks to be the same.

kernel-2.6.29.1-100.fc11.x86_64
xorg-x11-drv-intel-2.7.0-1.fc11.x86_64
xorg-x11-server-Xorg-1.6.1-6.fc11.x86_64
Comment 7 cje 2009-04-21 11:39:01 EDT
i've done an strace on my eeepc901 and it looks the same as bug 495497:

setitimer(ITIMER_REAL, {it_interval={0, 20000}, it_value={0, 20000}}, NULL) = 0
clock_gettime(CLOCK_MONOTONIC, {404, 950441573}) = 0
read(126, "\n\0\2\0S\0\300\r\2\0\4\0\36\0\300\r\1\0\0\0\0\0\0\0\2\0\4\0T\0\300\r\1"..., 4096) = 4096
clock_gettime(CLOCK_MONOTONIC, {404, 950960492}) = 0
write(2, "Xorg: i830_batchbuffer.h:78: inte"..., 105) = 105
rt_sigprocmask(SIG_UNBLOCK, [ABRT], NULL, 8) = 0
tgkill(1792, 1792, SIGABRT)             = 0
--- SIGABRT (Aborted) @ 0 (0) ---
Process 1792 detached
Comment 8 cje 2009-04-21 11:41:06 EDT
apologies - i shouldn't have cleared the NEEDINFO.  the fact that it looks the same on my PC doesn't mean it's the same on the reporter's.
Comment 9 Adam Williamson 2009-04-21 14:10:53 EDT
Well, that's two votes at least that it's the same issue...Mads, can you please check, and if it seems the same for you, I'll close this as a dupe. Thanks.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 10 Mads Villadsen 2009-04-21 18:04:36 EDT
It does indeed look like the same issue. Here are some lines from my
.xsession-errors

gnome-session[2209]: WARNING: Detected that screensaver has left the bus
** Message: Got disconnected from the session message bus; retrying to
reconnect every 10 seconds
gnome-settings-daemon: Fatal IO error 104 (Connection reset by peer) on X
server :0.0.
Window manager warning: Fatal IO error 11 (Resource temporarily unavailable) on
display ':0.0'.
gnome-panel: Fatal IO error 11 (Resource temporarily unavailable) on X server
:0.0.
gnome-session: Fatal IO error 11 (Resource temporarily unavailable) on X server
:0.0.


Another thing I noticed was that after X restarted and returned to the GDM
screen it was no longer running on tty1 but was now on tty7 - is that expected
behaviour after a crash?
Comment 11 Adam Williamson 2009-04-21 18:29:45 EDT
Thanks. Let's close this as a dupe then. Please follow along in the other report now :)

Mads: it's definitely known, I remember someone mentioning the same issue to me before. I'm not sure if it's considered something problematic that should be fixed, though.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 495497 ***

Note You need to log in before you can comment on or make changes to this bug.