Bug 495652 - rfkill not allow up power wifi
rfkill not allow up power wifi
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
i686 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-14 05:23 EDT by Jaroslav Zeman
Modified: 2009-04-15 11:52 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-15 11:52:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Zeman 2009-04-14 05:23:00 EDT
I am not find method how set power up for me wifi card iwl3945. I have HP/Compaq 6510b. (WIFI still on state off)

1. after: 
  ifconfig wlan0 up
get: 
  SIOCSIFFLAGS: Takové zařízení neexistuje (from czech -> device not exists)

2. after: 
iwconfig
get:
  wlan0   IEEE 802.11abg  ESSID:""
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated
          Tx-Power=0 dBm
          Retry min limit:7   RTS thr:off   Fragment thr=2352 B
          Encryption key:off
          Power Management:on
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

3. after: 
cat /var/log/messages
get:
  Apr  9 09:53:36 jarda kernel: iwl3945 0000:10:00.0: PCI INT A -> GSI 17 (level,
low) -> IRQ 17
  Apr  9 09:53:36 jarda kernel: iwl3945: Radio disabled by SW RF kill (module
parameter)

4. after remove and add module iwl3945 to kernel (modprobe -r iwl3945  modprobe iwl3945 disable=0) get after cat /var/log/messages:
  kernel: iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux, 1.2.26kds
  kernel: iwl3945: Copyright(c) 2003-2008 Intel Corporation
  kernel: iwl3945 0000:10:00.0: PCI INT A -> GSI 17 (level,low) -> IRQ 17
  kernel: iwl3945: Detected Intel Wireless WiFi Link 3945ABG
  kernel: iwl3945: Tunable channels: 13 802.11bg, 23 802.11a channels
  NetworkManager: <info>  (wlan0): driver supports SSID scans (scan_capa 0x01).
  NetworkManager: <info>  (wlan0): new 802.11 WiFi device (driver: 'iwl3945')
  NetworkManager: <info>  (wlan0): exported as /org/freedesktop/Hal/devices/net_00_1b_77_96_e2_00_0

5. after:
  iwlist wlan0 scanning
get:
  wlan0     Interface doesn't support scanning : Network is down
  (in message is repeat status from point 3. see above)

6. after:
  cd /sys/devices/pci0000:00/0000:00:1c.1/0000:10:00.0/rfkill/rfkill0/
  echo 1>state
  cat state
get:
  2

7. after:
  cd /proc/acpi
  cat wakeup
get:
  C0B0      S5     disabled  pci:0000:00:1e.0
  C108      S3     disabled  pci:0000:00:1d.0
  C10F      S3     disabled  pci:0000:00:1d.1
  C110      S3     disabled  pci:0000:00:1d.2
  C111      S3     disabled  pci:0000:00:1d.7
  C119      S3     disabled  pci:0000:00:1a.0
  C11A      S3     disabled  pci:0000:00:1a.1
  C11B      S3     disabled  pci:0000:00:1a.7
  C131      S5     disabled  pci:0000:00:1c.1
  C2A1      S5     disabled  pci:0000:10:00.0
  C132      S0     disabled  pci:0000:00:1c.2
  C137      S0     disabled  pci:0000:18:00.0
  C134      S5     disabled  pci:0000:00:1c.4
  C2A2      S5     disabled
  C23D      S5     disabled

8. after:
   dmesg | grep -e iwl -e wlan0
get:
  iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux, 1.2.26kds
  iwl3945: Copyright(c) 2003-2008 Intel Corporation
  iwl3945 0000:10:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
  iwl3945 0000:10:00.0: setting latency timer to 64
  iwl3945: Detected Intel Wireless WiFi Link 3945ABG
  iwl3945: Tunable channels: 13 802.11bg, 23 802.11a channels
  phy0: Selected rate control algorithm 'iwl-3945-rs'
  iwl3945 0000:10:00.0: PCI INT A disabled
  iwl3945 0000:10:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
  iwl3945 0000:10:00.0: restoring config space at offset 0x1 (was 0x100002, writing 0x100006)
  firmware: requesting iwlwifi-3945-1.ucode
  iwl3945: Radio disabled by HW RF Kill switch
  iwl3945 0000:10:00.0: PCI INT A disabled
  iwl3945 0000:10:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
  iwl3945 0000:10:00.0: restoring config space at offset 0x1 (was 0x100002, writing 0x100006)
  iwl3945: Radio disabled by HW RF Kill switch
  iwl3945 0000:10:00.0: PCI INT A disabled
  iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux, 1.2.26kds
  iwl3945: Copyright(c) 2003-2008 Intel Corporation
  iwl3945 0000:10:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
  iwl3945 0000:10:00.0: setting latency timer to 64
  iwl3945: Detected Intel Wireless WiFi Link 3945ABG
  iwl3945: Tunable channels: 13 802.11bg, 23 802.11a channels
  phy0: Selected rate control algorithm 'iwl-3945-rs'
  iwl3945 0000:10:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
  firmware: requesting iwlwifi-3945-1.ucode
  iwl3945: Radio disabled by HW RF Kill switch
  iwl3945 0000:10:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
  iwl3945: Radio disabled by HW RF Kill switch
  iwl3945 0000:10:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
  iwl3945: Radio disabled by HW RF Kill switch
  iwl3945 0000:10:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
  iwl3945: Radio disabled by HW RF Kill switch
  iwl3945 0000:10:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
  iwl3945: Radio disabled by HW RF Kill switch
  iwl3945: Error sending REPLY_CARD_STATE_CMD: iwl3945_enqueue_hcmd failed: -5

How up power wifi? Which button up wifi and find his settings, and his keyboard assignments?
Comment 1 John W. Linville 2009-04-14 08:53:05 EDT
In #5, make sure you do "ifconfig wlan0 up" _before_ "iwlist wlan0 scan".

However, "iwl3945: Radio disabled by HW RF Kill switch" suggests that you still have the rfkill switch activated.  Check closely -- some laptops have actual 'slider' switches (and not just a simple toggle button).

The "Error sending REPLY_CARD_STATE_CMD" line suggests there could be a bigger problem, but I'd rather not concentrate on that until the rfkill issue is resolved.
Comment 2 Jaroslav Zeman 2009-04-14 12:38:41 EDT
Command iwlist wlan0 scan not really works, because not works #1 (ifconfig wlan0 up).

My question is, how I am deactivate rfkill, or find how key using rfkill for deactivating?
Or how setting rfkill to sow-switch. I am no find help or config for rfkill.

This bug I am reported to section wifi - iwl3945 and bug is closed, because problem the say is in rfkill not in iwl3945.
Comment 3 John W. Linville 2009-04-14 13:25:08 EDT
Honestly, I have to refer you to the hardware manufacturer for help finding the rfkill switch:

   http://h20000.www2.hp.com/bizsupport/TechSupport/DocumentIndex.jsp?contentType=SupportManual&lang=en&cc=us&docIndexId=64179&taskId=101&prodTypeId=321957&prodSeriesId=3355650
Comment 4 Jaroslav Zeman 2009-04-15 02:39:29 EDT
Please, please, I do not want use rfkill utility. Respective I am want set this utility to software mode, and set power up wifi over command line. Sorry, I am not have time, bargain with notebook producer, which support only windows. 

If some body add utility (for example rfkill) to kernel, that I am assume, so when insert to Google "rfkill setting", on first reference I am find settings this utility and not find more as 100 bugs over all Unix platforms!
Comment 5 John W. Linville 2009-04-15 11:52:12 EDT
"Radio disabled by HW RF Kill switch" strongly suggests that there is a physical switch somewhere that you have set incorrectly.  Either that, or your wireless device is disabled in the BIOS.  This does not appear to be a software related (or software fixable) problem.

Note You need to log in before you can comment on or make changes to this bug.