Bug 495682 - [kms] Font corruption on ATI Radeon X800 when both exa and modesetting are enabled
[kms] Font corruption on ATI Radeon X800 when both exa and modesetting are en...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-14 08:05 EDT by Joachim Frieben
Modified: 2009-04-21 10:19 EDT (History)
1 user (show)

See Also:
Fixed In Version: xorg-x11-drv-ati-6.12.2-4.fc11.x86_64
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-21 10:19:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of xmgrace with active modesetting (14.25 KB, image/png)
2009-04-14 08:05 EDT, Joachim Frieben
no flags Details
Custom xorg.conf for ATI Radeon X800 and 21" CRT HP A4576A (1019 bytes, text/plain)
2009-04-14 08:07 EDT, Joachim Frieben
no flags Details
Xorg.0.log with active modesetting (72.72 KB, text/plain)
2009-04-14 08:08 EDT, Joachim Frieben
no flags Details

  None (edit)
Description Joachim Frieben 2009-04-14 08:05:53 EDT
Created attachment 339469 [details]
Screenshot of xmgrace with active modesetting

Description of problem:
For a fully updated "rawhide" system, button labels are incomplete after launching xmgrace.

Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.12.1-10.fc11.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Boot X with kernel modesetting.
2. Launch 'xmgrace'.
  
Actual results:
Certain buttons are empty or show character fragments only.

Expected results:
Buttons are rendered correctly.

Additional info:
No artifacts appear after booting system with kernel option "nomodeset" for both acceleration methods "exa" and "xaa". Thus, the issue is a pure modesetting problem.
Comment 1 Joachim Frieben 2009-04-14 08:07:13 EDT
Created attachment 339470 [details]
Custom xorg.conf for ATI Radeon X800 and 21" CRT HP A4576A
Comment 2 Joachim Frieben 2009-04-14 08:08:06 EDT
Created attachment 339472 [details]
Xorg.0.log with active modesetting
Comment 3 Joachim Frieben 2009-04-21 10:19:13 EDT
I have just checked whether the issue was still present, and as of xorg-x11-drv-ati-6.12.2-4.fc11.x86_64, it is resolved.

Note You need to log in before you can comment on or make changes to this bug.