Bug 495786 - RHEL 4 clients still show update pkgs even after a selecting all updates and rhn_check
RHEL 4 clients still show update pkgs even after a selecting all updates and ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Client (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Justin Sherrill
wes hayutin
https://grandprix.rhndev.redhat.com/r...
:
Depends On:
Blocks: 456985
  Show dependency treegraph
 
Reported: 2009-04-14 15:30 EDT by wes hayutin
Modified: 2009-09-10 16:35 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 16:35:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ss1 (431.31 KB, image/png)
2009-04-14 15:31 EDT, wes hayutin
no flags Details
ss2 (397.59 KB, image/png)
2009-04-14 15:31 EDT, wes hayutin
no flags Details

  None (edit)
Description wes hayutin 2009-04-14 15:30:17 EDT
Description of problem:
4/13 build x86 rhel 5 server

RHEL 4 clients still show update pkgs even after a selecting all updates and rhn_check 

recreate:
1. register rhel4
2. update all errata on system
3. rhn_check

sdc details still shows pkgs left to be updated..
However no pkgs listed here:
https://grandprix.rhndev.redhat.com/rhn/systems/details/packages/UpgradableList.do?sid=1000010501

will add screenshots
Comment 1 wes hayutin 2009-04-14 15:31:13 EDT
Created attachment 339562 [details]
ss1
Comment 2 wes hayutin 2009-04-14 15:31:39 EDT
Created attachment 339563 [details]
ss2
Comment 3 Justin Sherrill 2009-04-14 15:55:17 EDT
commit:

6be3fe9

Issue was that due to a previous bug (487234) updates were ignored if the client hadn't uploaded the arch info for their installed packages.  Changed query to not ignore installed packages with null arch_id
Comment 4 wes hayutin 2009-04-23 13:15:11 EDT
verified 4/22.2 build
Comment 5 Jan Pazdziora 2009-09-07 09:15:03 EDT
Stage validated on Satellite-5.3.0-RHEL5-re20090820.1. I've updated my old-ish RHEL 4 to be up-to-date. The number of packages went down as the erratas were applied, and now the system status reported in the WebUI is "System is up to date".

It was important to put

pkgSkipList=

to /etc/sysconfig/rhn/up2date to override the default kernel*, otherwise the kernel erratas were not applied.

Moving to RELEASE_PENDING.
Comment 6 Brandon Perkins 2009-09-10 16:35:33 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.