Bug 495787 - rhnpush --force option disabled in Satellite when it should only be disabled in Spacewalk
rhnpush --force option disabled in Satellite when it should only be disabled ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
530
All Linux
medium Severity medium
: ---
: ---
Assigned To: Devan Goodwin
Steve Salevan
:
Depends On:
Blocks: 463876
  Show dependency treegraph
 
Reported: 2009-04-14 15:33 EDT by Steve Salevan
Modified: 2009-09-10 14:54 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 14:54:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Salevan 2009-04-14 15:33:45 EDT
Description of problem:
If a user attempts to push a package via rhnpush with the --force option to a 530 Satellite, the user will receive an error stating that --force has been disabled.

Upon consulting with Pradeep, it appears that this feature should only be disabled for Spacewalk, where the following line in /etc/rhn/rhn.conf appears as follows:

force_package_upload=0

This line should be changed with the Satellite branding package and should read:

force_package_upload=1

Version-Release number of selected component (if applicable):
530-re20090409.1

How reproducible:
Always

Steps to Reproduce:
1. Attempt to push a package to a Satellite using rhnpush and adding the --force command-line option
  
Actual results:
Error received on console stating that --force is disabled, package not pushed

Expected results:
Package pushed

Additional info:
Comment 1 Devan Goodwin 2009-04-22 10:18:58 EDT
Looks like this was disabled in spacewalk.git commit f8572eda5ea4e55660759fecd23414f3349e17ff, commit message doesn't clearly state one way or the other but it looks like it was done in a way that it could be re-enabled for Satellite easily. (setting force_package_upload = 1) I'll ping Prad to make sure.
Comment 2 Devan Goodwin 2009-04-22 10:23:45 EDT
I should read original bug report more clearly as I see now you already discussed with prad. :) Will re-enable for Satellite.
Comment 3 Devan Goodwin 2009-04-22 10:30:38 EDT
Fixed in satellite.git 4044bd334def6ba00261911fd49f939057f80b41, fix will arrive in satellite-branding-5.3.0.18-1 but will require a re-run of spacewalk-setup if you're not doing a fresh install.
Comment 4 Steve Salevan 2009-05-14 12:48:29 EDT
VERIFIED in 5/7 build.
Comment 5 Petr Sklenar 2009-08-07 06:07:48 EDT
VERIFIED again in Satellite-5.3.0-RHEL4-re20090730.0-i386-embedded-oracle.iso
/etc/rhn/rhn.conf , force is by default set to 1:
force_package_upload=1

testing procedure : rhnpush run repeatedly with or without directive '--force' :

rhnpush -d /mnt/redhat/brewroot/packages/rpm/4.4.2.3/15.el5/x86_64/ --channel=main-channel --username=admin --password=*** --nosig --server=http://`hostname`/APP --force
Comment 7 Brandon Perkins 2009-09-10 14:54:45 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.